Bug 115609 - RFE: add support for 3C940 NIC using the sk98lin driver
Summary: RFE: add support for 3C940 NIC using the sk98lin driver
Status: CLOSED DUPLICATE of bug 115511
Alias: None
Product: Fedora
Classification: Fedora
Component: hwdata   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 19:53 UTC by Gene Czarcinski
Modified: 2014-03-17 02:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2004-02-13 19:53:00 UTC
Description of problem:

While the sk98lin driver is supported, the install does not recognize
that the 3Com 3C940 NIC uses this driver.  Please ad the capaboility
for auto recognition.  See:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115511

Comment 1 Gene Czarcinski 2004-02-14 15:39:19 UTC
Looking at anaconda, it appears that all of the pciids for sk98lin
related adapters are missing.  I am not an anaconda "expert" but
looking at isys/pci/pcitable (and pci.ids), there are no entries for
sk98lin drivers.  Specifically the 3Com 10b7:1700 for the 3C940 and
3C2000 as well as the SysKonnect 1148:4300 and 1148:4320.

The full set of supported NICs can be seen in the "horrible" code in
the kernel in drivers/net/sk98lin/h/skdrv2nd.h

Comment 2 Gene Czarcinski 2004-02-14 15:45:56 UTC
CC'ed everyon on 115511.

Comment 3 Gene Czarcinski 2004-02-14 16:10:50 UTC
Suggestion ...

/usr/share/hwdata/pci.ids seems to be very much up to date and has the
3C940 as well as SysKonnect ids.

If possible, there should be a single file which defines pci.ids ...
make hwdata a BuildReq for anaconda.

Comment 4 Bill Nottingham 2004-02-16 04:24:05 UTC
This bug has nothing to do with anaconda, per se.

Comment 5 Bill Nottingham 2004-02-16 04:24:29 UTC

*** This bug has been marked as a duplicate of 115511 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:01:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.