Bug 115619 - [PATCH] ghostscript still built against glib1/gtk1
[PATCH] ghostscript still built against glib1/gtk1
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: ghostscript (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 17:26 EST by W. Michael Petullo
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version: 7.07-23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-18 05:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to ghostscript-7.07-19's .spec file that builds the RPM using glib2/gtk2 (1.17 KB, patch)
2004-02-13 17:34 EST, W. Michael Petullo
no flags Details | Diff
Causes gsx to build against gtk2. (715 bytes, patch)
2004-02-13 17:35 EST, W. Michael Petullo
no flags Details | Diff
Causes Omni code to build against glib2. (4.49 KB, patch)
2004-02-13 17:37 EST, W. Michael Petullo
no flags Details | Diff

  None (edit)
Description W. Michael Petullo 2004-02-13 17:26:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
The ghostscript package is still built against glib and gtk+ version
1.x.  However, it does seem that all of the code is source-compatible
with glib and gtk+ 2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Notice that gsx requires glib and gtk+ 1.x.
    

Additional info:
Comment 1 W. Michael Petullo 2004-02-13 17:34:04 EST
Created attachment 97664 [details]
Patch to ghostscript-7.07-19's .spec file that builds the RPM using glib2/gtk2

The following patches are needed to build ghostscript-7.07-19 using glib2 and
gtk2:

1.  This patch (patch of .spec file)
2.  ghostscript-7.07-gtk2.patch (later in bug report)
3.  ghostscript-7.07-omni-glib2.patch (later in bug report)

Patch ghostscript.spec using this patch, put the other two patches in your
%_topdir/SOURCES and then run rpmbuild.
Comment 2 W. Michael Petullo 2004-02-13 17:35:37 EST
Created attachment 97666 [details]
Causes gsx to build against gtk2.
Comment 3 W. Michael Petullo 2004-02-13 17:37:23 EST
Created attachment 97667 [details]
Causes Omni code to build against glib2.
Comment 4 Tim Waugh 2004-02-18 05:58:43 EST
Thanks very much!  Applied in 7.07-23.

Note You need to log in before you can comment on or make changes to this bug.