Bug 115629 - up2date privacy statement not shown
up2date privacy statement not shown
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 18:58 EST by Walker Aumann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 13:02:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Walker Aumann 2004-02-13 18:58:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
up2date registration process shows a dialog for accepting the privacy
agreement, but shows no privacy agreement (blank window).

Version-Release number of selected component (if applicable):
up2date-4.3.11-2

How reproducible:
Always

Steps to Reproduce:
1. up2date --register
2.
3.
    

Actual Results:  Window displaying "Step 1: Review the Red Hat Privacy
Statement".  The statement itself is blank or does not appear.

Expected Results:  Full text of privacy statement displayed.

Additional info:

The initial warning (GtkTextSearchFlags) happens before the window
first appears.

[root@localhost root]# up2date --register
 
** (up2date:15619): WARNING **: `GtkTextSearchFlags' is not an enum type
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 410, in
onPrivacyPagePrepare    rhnreg.getCaps()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 204, in getCaps
    rpcServer.doCall(s.registration.welcome_message)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 112, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/lib/python2.3/xmlrpclib.py", line 1029, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.3/site-packages/rhn/rpclib.py", line 302, in
_request
    verbose=self._verbose
  File "/usr/lib/python2.3/site-packages/rhn/transports.py", line 167,
in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.3/site-packages/rhn/transports.py", line 688,
in send_http
    headers=self.headers)
  File "/usr/lib/python2.3/httplib.py", line 718, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.3/httplib.py", line 730, in _send_request
    if 'host' in [k.lower() for k in headers]:
AttributeError: 'NoneType' object has no attribute 'lower'
Comment 1 Barry K. Nathan 2004-07-14 08:00:39 EDT
I can't reproduce this with FC-devel as of 20040713 (the privacy
statement appears in full). I think this bug has been fixed now.

Note You need to log in before you can comment on or make changes to this bug.