Bug 115640 - Request to upgrade to mysql-4.x
Request to upgrade to mysql-4.x
Status: CLOSED DUPLICATE of bug 100517
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
http://www.mysql.com
: FutureFeature
: 115653 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 21:01 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-02-13 21:01:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET 
CLR 1.1.4322)

Description of problem:
Hi, people, I just would like to request the upgrade to the stable 
4.x version of mysql since this now the official stable steam, I saw 
in the past this upgrade in the rawhide but was removed, any reason 
to do this???

Version-Release number of selected component (if applicable):
mysql-3.23.58

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora
2.
3.
    

Additional info:
Comment 1 Bill Nottingham 2004-02-16 01:52:33 EST
*** Bug 115653 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2004-02-16 01:55:44 EST
FWIW, there are license issues with upgrading to mysql-4.x.
Comment 3 Need Real Name 2004-02-16 10:56:41 EST
Hi Bill, I've reading the MySQL license and I saw this....

You need to purchase commercial non-GPL MySQL licenses: 

If you distribute MySQL Software with your non open source software, 
If you want warranty from MySQL AB for the MySQL software, 
If you want to support MySQL development. 

As you can see Fedora is a open source software, so I don't see any 
problem in upgrading to mysql-4.x, but to upgrade in RedHat 
Enterprise Linux yes, now, we are talking here of Fedora, wich is 
supposed to be a really OpenSource Linux distro, there are a lot of 
Linux distros around there with mysql-4.x already in. Mysql has been 
the preferred among the years for web sites and in many others apps, 
Then why it can't be included in Fedora???
Maybe I'm wrong....???
Regards Aliet
 
Comment 4 Patrick Macdonald 2004-02-16 12:23:15 EST
They MySQL folks changed the licensing from 3.23 to 4.0 and we are not
able to ship (in any release) the 4.0x packages until MySQL changes the
licensing.  There are licensing conflicts with MySQL 4.0 and PHP,
for example, that are not there with MySQL 3.23x.  This is a known
problem and it has been sent upstream.  As soon as we get the green
light, we'll move to 4.0.

*** This bug has been marked as a duplicate of 100517 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:01:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.