Bug 115647 - Error in gstreamer post-install scriptlet
Error in gstreamer post-install scriptlet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 115645 115646 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-14 00:14 EST by Bob Arendt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-14 13:51:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Arendt 2004-02-14 00:14:45 EST
The gstreamer postinstall scriptlet fails during installation:

   2:gstreamer             
########################################### [ 40%]
error: %post(gstreamer-0.7.3-3) scriptlet failed, exit status 127

Version info:
   % rpm -q gstreamer
   gstreamer-0.7.3-3

The postinstall scriptlet:
  % rpm -q --scripts gstreamer
  postinstall scriptlet (using /bin/sh):
  /sbin/ldconfig
  env DISPLAY= /usr/bin/gst-register --gst-mask=0 > /dev/null 2> /dev/null
  postuninstall program: /sbin/ldconfig

The postinstall scriptlet looks strange.  gst-register is actually
installed as "gst-register-0.7" and the argument has changed.

I believe the following works to establish the gstreamer registry:
  /usr/bin/gst-register-0.7 --gst-plugin-spew
Comment 1 Bob Arendt 2004-02-14 12:39:04 EST
*** Bug 115645 has been marked as a duplicate of this bug. ***
Comment 2 Bob Arendt 2004-02-14 12:39:32 EST
*** Bug 115646 has been marked as a duplicate of this bug. ***
Comment 3 Bob Arendt 2004-02-14 13:51:50 EST
Looks like it's been fixed in development (rawhide?) tree:

% rpm -q --scripts gstreamer-plugins
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
env DISPLAY= /usr/bin/gst-register-0.7 >/dev/null 2>&1
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gstreamer.schemas"
for S in $SCHEMAS; do 
  gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
done
postuninstall scriptlet (using /bin/sh):
/sbin/ldconfig
env DISPLAY= /usr/bin/gst-register-0.7 >/dev/null 2>&1








Note You need to log in before you can comment on or make changes to this bug.