Bug 115664 - ifconfig segfaults on Fedora Core 2 / test 1
ifconfig segfaults on Fedora Core 2 / test 1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-14 10:13 EST by Michele Baldessari
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-06 16:45:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f log (6.72 KB, text/plain)
2004-02-14 10:16 EST, Michele Baldessari
no flags Details

  None (edit)
Description Michele Baldessari 2004-02-14 10:13:52 EST
Description of problem:

see above

Version-Release number of selected component (if applicable):

net-tools-1.60-20.1
kernel-2.6.1-1.65
glibc-2.3.3-7


How reproducible:
Always

Steps to Reproduce:

[root@birrella root]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:A0:CC:61:36:7D
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
Segmentation fault


Expected results:


Additional info:
Comment 1 Michele Baldessari 2004-02-14 10:16:47 EST
Created attachment 97669 [details]
strace -f log
Comment 2 Michele Baldessari 2004-02-14 10:18:07 EST
here is the backtrace from gdb (no debugging symbols, but it shows
where we crash)

Program received signal SIGSEGV, Segmentation fault.
0x005995e3 in match_prefix () from /lib/tls/libc.so.6
(gdb) bt
#0  0x005995e3 in match_prefix () from /lib/tls/libc.so.6
#1  0x005993e4 in rfc3484_sort () from /lib/tls/libc.so.6
#2  0x004fc9d0 in msort_with_tmp () from /lib/tls/libc.so.6
#3  0x004fc957 in msort_with_tmp () from /lib/tls/libc.so.6
#4  0x004fcbf8 in qsort () from /lib/tls/libc.so.6
#5  0x00598e4a in getaddrinfo () from /lib/tls/libc.so.6
#6  0x0804c8ba in ?? ()
#7  0xbff5b840 in ?? ()
(gdb)
Comment 3 Bill Nottingham 2004-02-16 02:02:17 EST
Any kernel messages at all?
Comment 4 Phil Knirsch 2004-02-16 04:19:13 EST
Could you provide a little more info on the hardware you are using?
We're running latest Rawhide on quite a few machines here and none of
them segfaults when using ifconfig.

Also maybe your DNS setup might be interessting as the app obviously
crashes in some address lookup.

Thanks,

Read ya, Phil
Comment 5 Michele Baldessari 2004-02-16 09:25:02 EST
Ciao Phil and Bill,

here we go:
- No kernel messages at all
- The hardware (P3 / 600Mhz) and dns setup is totally straightforward
(i.e. has been working fine when I reboot in fedora 1 or debian stable
and unstable). I have only one dns resolving nameserver (192.168.0.254)

I just finished upgrading some packages but it still happens:
[root@birrella root]# uname -r
2.6.2-1.79
[root@birrella root]# rpm -q net-tools
net-tools-1.60-20.1
[root@birrella root]# rpm -q glibc
glibc-2.3.3-8

note that 'ip addr' works fine:
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
    inet6 ff02::1/128 scope global
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:a0:cc:61:36:7d brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.2/24 brd 192.168.0.255 scope global eth0
    inet6 3ffe:b80:1a9d:0:2a0:ccff:fe61:367d/64 scope global dynamic
       valid_lft 2591669sec preferred_lft 604469sec
    inet6 fe80::2a0:ccff:fe61:367d/64 scope link
       valid_lft forever preferred_lft forever
    inet6 ff02::1:ff61:367d/128 scope global
       valid_lft forever preferred_lft forever
    inet6 ff02::1/128 scope global
       valid_lft forever preferred_lft forever
3: sit0: <NOARP> mtu 1480 qdisc noop qlen 1
    link/sit 0.0.0.0 brd 0.0.0.0

Ok. I see what it is. It's ipv6 related. If I remove any reference to
ipv6 addresses (I do have a radvd on this net btw.) and 'ip addr'
looks like this:

[root@birrella root]# ip addr
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:a0:cc:61:36:7d brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.2/24 brd 192.168.0.255 scope global eth0
3: sit0: <NOARP> mtu 1480 qdisc noop qlen 1

After this change ifconfig works as expected:
[root@birrella root]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:A0:CC:61:36:7D
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:348 errors:1 dropped:0 overruns:0 frame:0
          TX packets:331 errors:3 dropped:0 overruns:0 carrier:3
          collisions:0 txqueuelen:1000
          RX bytes:345419 (337.3 Kb)  TX bytes:35638 (34.8 Kb)
          Interrupt:5 Base address:0x5000
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:92 errors:0 dropped:0 overruns:0 frame:0
          TX packets:92 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5996 (5.8 Kb)  TX bytes:5996 (5.8 Kb)
 
Given that ifconfig is slowly fading out in favor of ip I'll lower the
severity. 
Hth,
Michele
Comment 6 Barry K. Nathan 2004-07-14 07:53:58 EDT
Do you still have this bug in FC2 final or FC3 test 1?
Comment 8 Radek Vokal 2005-02-06 16:45:45 EST
Seems to be fixed, closing as CURRENT RELEASE

Note You need to log in before you can comment on or make changes to this bug.