Bug 115695 - yum upgrade from FC1 to FC2 test1 reports disk space incorrectly
yum upgrade from FC1 to FC2 test1 reports disk space incorrectly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-14 19:44 EST by David Ritchey
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-14 22:20:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Ritchey 2004-02-14 19:44:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
Currently running a fully updated FC1 install, trying to use yum to
upgrade to FC2 test1. Command used to attempt upgrade = 'yum upgrade'.

yum states the upgrade requires 538MB on /. There is currently 1.1gig
available but yum stops with the error:

Errors installing:
('installing package kernel-source-2.6.1-1.65 needs 38MB on the /
filesystem', (9, '/', 38875136L))
<snip>
('installing package gnome-session-2.5.3-1 needs 538MB on the /
filesystem', (9, '/', 563412992L))

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda2             4.0G  2.8G  1.1G  72% /
/dev/hda1              99M  8.3M   86M   9% /boot
/dev/hda5             6.0G  1.4G  4.3G  24% /home
none                  252M     0  252M   0% /dev/shm
/dev/hda3             7.9G  4.9G  2.6G  66% /var



Version-Release number of selected component (if applicable):
yum-2.0.4.20040103-1

How reproducible:
Always

Steps to Reproduce:
1. change yum.conf to point to new test1 repository
2. manually upgrade fedora-release package
3. yum upgrade
4. answer y to package changes
    

Actual Results:  Error, not enough disk space. Space is available.

Expected Results:  Upgrade from FC1 to FC2 test1.

Additional info:

I tried this with the FC1 yum version, and the FC2 test1 version.
Comment 1 Jeff Johnson 2004-02-14 22:20:24 EST
The message says "needs", as in requires 538MB additional
to what already exists.
Comment 2 Patrice Dumas 2004-08-18 17:35:44 EDT
I had the same experience (yum needing space although there was plenty
left), and then I updated piecewise, with

$ yum update 'a*' 'b*' 'c*' 'd*' 'e*' 'f*' 'g*' 

and so on, it worked and I still have space left.

I reported it to the yum list, but seth said that it is a bug in rpm
that don't report the right space.

Note You need to log in before you can comment on or make changes to this bug.