Bug 115700 - pdfmark blows up gs 7.07, kaboom!
pdfmark blows up gs 7.07, kaboom!
Status: CLOSED DUPLICATE of bug 115396
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2004-02-14 21:31 EST by Rick Richardson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Input file used to torture gs 7.07 (as shipped in FC2 test1) (63.18 KB, text/plain)
2004-02-14 21:35 EST, Rick Richardson
no flags Details

  None (edit)
Description Rick Richardson 2004-02-14 21:31:57 EST
The attached Postscript file causes the below listed error when
processing the pdfmarks in the file using the command below.  This
problem did not occur with gs 7.05 (shipped with RH8, for example). 
It only occurs with gs 7.07.  It is a complete show stopper for me to
upgrade past RH8 until it is fixed.

$ ps2pdf gs707error.ps xxx.pdf
Error: /rangecheck in --pdfmark--
Operand stack:
   --nostringval--   --nostringval--   PageMode   UseOutlines   Page 
 1   View   --nostringval--   DOCVIEW
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   false   1   %stopped_push   1   3
  %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   1   3 
 %oparray_pop   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   9   5  
%oparray_pop   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1065/1123(ro)(G)--   --dict:0/20(G)--   --dict:89/200(L)-- 
 --dict:55/120(L)--   --dict:1/57(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 5976
GNU Ghostscript 7.07: Unrecoverable error, exit code 1
Comment 1 Rick Richardson 2004-02-14 21:35:18 EST
Created attachment 97679 [details]
Input file used to torture gs 7.07 (as shipped in FC2 test1)

This file works great with gs 7.05 (as shipped with RH8), and I believe it also
works fine with gs 8.0 (as compiled by me).
Comment 2 Tim Waugh 2004-02-15 14:23:10 EST

*** This bug has been marked as a duplicate of 115396 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.