Bug 115712 - Dancing and waving when input Japanese string
Dancing and waving when input Japanese string
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 05:23 EST by Nakai
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 02:05:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gcc -g -Wall -o main main.c `pkg-config gtk+-2.0 --cflags --libs` (398 bytes, text/plain)
2004-02-15 05:42 EST, Nakai
no flags Details

  None (edit)
Description Nakai 2004-02-15 05:23:30 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run gedit in Japanese environment
2. Shift + Space to start Japanese input
3. Press key 'n' and repeat several times
4. And even non-Japanese can see the input preedit is dancing.
  
Actual results:
Position of string in preedit area moves along with the last
char type in preedit. When the preedit last char is Japanese char,
the baseline is rather upper. When the preedit last char is
alphabet, the baseline is rather lower.

Expected results:
String in preedit area should looks like as if it was really
commited, and should not move.

Additional info:
- This doesn't seem to be a gedit upstream bug. Font setting issue is
the distro's.
- This bug never happen on Windows. Let's learn how great Microsoft's
i18n is and who sucks.
- This bug doesn't happen on gnome-terminal.
Comment 1 Nakai 2004-02-15 05:35:58 EST
Reassign gtk+2, because this also happens on the simple test
file attached.
Comment 2 Nakai 2004-02-15 05:42:12 EST
Created attachment 97684 [details]
gcc -g -Wall -o main main.c `pkg-config gtk+-2.0 --cflags --libs`
Comment 3 Jens Petersen 2005-11-29 02:05:30 EST
I see it still in FC4, but I can't reproduce this with current rawhide.

Note You need to log in before you can comment on or make changes to this bug.