Bug 115726 - Floppy works befor install, but after it will not
Floppy works befor install, but after it will not
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 08:41 EST by Perfect Human
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-02 10:28:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perfect Human 2004-02-15 08:41:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1

Description of problem:
I had this problem that is femiliar to Bugs (57253-60887-64046-75687)
but the difrence is that my mutherboard is (ASUS P4T-F) but same Asus
and the I am using RedHat 9 (2.4.20-8 Kernel that comes with it)
I tried all the ways that mensioned in the bugs above
and still get:
-----------
Floppy drive(s): fd0 is 1.44M
floppy0: no floppy controllers found
-----------

even with (Plug & Play O/S=No) in bios
and the strange thing is that while installing, the emergency boot
disk was made successfully, but after i finish i get that up message.
and when i run the PC from the RedHat CD, and choose 'linux rescue'
and try to mount the floppy with:
'mount -t auto /dev/fd0 /mnt/xxx' the floppy is succefuly mounted,
but normal booting says:
"mount: /dev/fd0 is not a valid block device"
i found this strange.. WHY?

I will type here what i did, in case i did something wrong
CoZ i have a short experiance in linux (I installed redHat linux a
month ago):


Steps to Reproduce:
1.I added '+' befor some lines in 'bootsect.S' file
in '/usr/src/linux-2.4.20-8/arch/i386/boot' as folows:
----------
kill_motor:
+#if 1
+	xorw	%ax, %ax		# reset FDC
+	xorb	%dl, %dl
+	int	$0x13
+#else
	movw	$0x3f2, %dx
	xorb	%al, %al
	outb	%al, %dx
+#endif
----------
(i think the '#' sign is to drop the line, but why the '+' for.. i
don't know)
anyway .. it didn't work (the same 'no floppy controllers found')

2.i tried to say:
cd /usr/src/linux-2.4.20-8   (or 'cd /usr/src/linux-2.4')
make xconfig
i choosed 'Block Devices'
i make 'Normal floppy disk support' as module
i chose 'Save and exit'
the 'xconfig' told me to do a 'make dep' so i did it were i am
and it didn't work too (the same 'no floppy controllers found')

3.i tried the same as above:
cd /usr/src/linux-2.4.20-8   (or 'cd /usr/src/linux-2.4')
make xconfig
i choosed 'ATA/IDE/MFM/RLL support'
i choosed 'IDE,ATA, and ATAPE block devices'
i make 'Use multi-mode by default' to 'No'
i chose 'Save and exit'
and the 'xconfig' told me to do a 'make dep' so i did it
and it didn't work too.


How reproducible:
Always


Actual Results:  Same problem

Expected Results:  It should work fine

Additional info:

(all the three ways i tried here are some solutions from
Bugs (57253-60887-64046-75687) here
But why don't they work with me? .. somethink i didn't do
correctly? (i'm new on linux.. so help me)

by the way.. when i use 'dmesg' to dislpy what was typed
while booting, a line apears:

'ide-floppy driver 0.99.newide'

does this mean anything?

Is there anyone can help me with this?
Thanx for even trying..
Comment 1 Perfect Human 2004-02-17 17:57:15 EST
Hi..
i just wanted to say.. that i don't think this is a kernel problem 
(just baybe) CoZ as i said.. i booted from RedHat CD, and 
choosed 'linux rescue'. and the floppy was mounted successfully. but 
if you see that it is a kernel matter. maybe.. could it be fixed? i 
hope so...
Comment 2 Perfect Human 2004-07-02 10:25:31 EDT
Well... nobody had any comment????
AnyWay!!!

I upgraded the kernel to 2.6.6 and the floppy works fine now

not perfectly.. but it works fine

(Just for who is passing by)

Note You need to log in before you can comment on or make changes to this bug.