Bug 115730 - Font sizes are off
Font sizes are off
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 10:00 EST by Simon Perreault
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 17:23:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Tahoma at size 8 in Qt and GTK (54.12 KB, image/png)
2004-02-15 10:01 EST, Simon Perreault
no flags Details
Luxi Sans (Fedora's default font) at size 8 in Qt and GTK (53.83 KB, image/png)
2004-02-15 10:02 EST, Simon Perreault
no flags Details

  None (edit)
Description Simon Perreault 2004-02-15 10:00:39 EST
Description of problem: 
Font sizes are off in Qt. When I select the exact same font with the 
exact same size in Qt and GTK programs, the fonts in Qt are not the 
same size as the GTK fonts. It is most visible at 8 pts, where the 
Qt font will be much smaller than its GTK equivalent. 
 
The GTK font size is the correct one. It is also the size of the old 
Qt, the one that was present in FC1. 
 
It has now become impossible to choose an 8 point Tahoma font the 
same size as in Windows (I like that font size). 8 pts in Qt is too 
small, and 9 pts is too big. So the font sizes in Qt are not simply 
off by one, there are font sizes missing. Something weird is going 
on. 
 
Version-Release number of selected component (if applicable): 
3.2.3-0.2 
 
How reproducible: 
To compare fonts, I simply start gnome-control-center and use the 
Fonts section to browse fonts. In KDE I use kcontrol in the fonts 
section.
Comment 1 Simon Perreault 2004-02-15 10:01:42 EST
Created attachment 97687 [details]
Tahoma at size 8 in Qt and GTK

See that the font in Qt is smaller than the one in GTK.
Comment 2 Simon Perreault 2004-02-15 10:02:42 EST
Created attachment 97688 [details]
Luxi Sans (Fedora's default font) at size 8 in Qt and GTK

See that the font in Qt is again smaller than its equivalent in GTK.
Comment 3 Ngo Than 2004-02-26 05:21:01 EST
could you please try qt-3.3.0 in rawhide. I don't see this problem
anymore. Thanks
Comment 4 Simon Perreault 2004-03-02 23:36:25 EST
Nope, the problem is still there. 
 
I verified with stock Qt and KDE compiled from source and the bug is 
there. So this does not seem to be a problem with Red Hat's 
packages. 
 
One thing seems to solve (well, at least, modify it) the bug: 
in /etc/X11/Xresources, comment out the 
 
Xft.dpi: 96 
 
line. 
 
Comment 5 Simon Perreault 2004-03-03 00:39:56 EST
Ok, let's keep the DPI to 96. Commenting it out is actually not a
solution, as browsing the web quickly let me know.

I took a couple of screenshots to help diagnose the problem. All of
them with 96 dpi. What they were viewing:
http://nomis80.org/fonttest.html.

First of all, the Windows screenshot. This is the benchmark. I took it
with Firefox, but Internet Explorer displayed exactly the same.
http://nomis80.org/windows_96dpi.png

With Firefox in Linux. See that the font sizes are exactly the same as
in Windows.
http://nomis80.org/firefox_96dpi.png

Then with Qt. I tried with Konqueror, but this thing does weird things
with fonts and so I did not trust it. I created a Qt Designer file
with basically the same info: http://nomis80.org/fonttest.ui. Only the
Tahoma font at 9pt is wrong. But this is exactly the font I want!
http://nomis80.org/qt_96dpi.png

This problem may not seem important, but if font sizes are wrong for
Tahoma 9pt, they very well might be for other fonts at other sizes.
And graphic designers can't rely on Qt programs on Fedora because of
that. So it is not a wishlist, but also not a very important bug.

Also, the problem is not with Red Hat packages because a stock Qt has
the same bug. So you may close this bug, I'll forward it to Trolltech.

Note You need to log in before you can comment on or make changes to this bug.