Bug 115734 - random freezes with FC2 Test1
random freezes with FC2 Test1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 10:42 EST by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-19 08:17:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from "cat /proc/cpuinfo" (407 bytes, text/plain)
2004-03-23 16:14 EST, Bernd Bartmann
no flags Details
output of "lspci -vv" (10.10 KB, text/plain)
2004-03-23 16:15 EST, Bernd Bartmann
no flags Details
output of "dmesg" (10.49 KB, text/plain)
2004-03-23 16:15 EST, Bernd Bartmann
no flags Details

  None (edit)
Description Bernd Bartmann 2004-02-15 10:42:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
My system (Athlon 2200 XP+, K7S5A mainboard) randomly freezes with the
FC2 Test1 kernel. Nothing interesting can be found in
/var/log/messages after the lock-up.

Any idea how to further debug this problem?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. wait for system lock-ups
2.
3.
    

Additional info:
Comment 1 Sahil Verma 2004-03-16 19:30:12 EST
Wild guesswork:

- boot with acpi=off
- Overclocked CPU? Does it get too hot? Power supply?
- get the latest BIOS from ECS

How often does it lockup - light load, heavy load or no load.

Post your dmesg and /proc/cpuinfo as attachments, maybe someone can
take a look.

Also upgrade to the latest kernel.
Comment 2 Bernd Bartmann 2004-03-23 16:14:01 EST
I already tested with acpi=off and on. CPU is not overclocked.
Temparature is normal. Power supply is a 365W ENERMAX. BIOS is already
updated. Kernel is now 2.6.3-2.1.253.2.1.

The lockups do not depend on the load. It just locked up during
up2date. Yesterday I just left the system running idle for ~ 3 hours
and it locked again.

I'll attach /proc/cpuinfo, lspci -vv and dmesg output.
Comment 3 Bernd Bartmann 2004-03-23 16:14:37 EST
Created attachment 98802 [details]
output from "cat /proc/cpuinfo"
Comment 4 Bernd Bartmann 2004-03-23 16:15:05 EST
Created attachment 98803 [details]
output of "lspci -vv"
Comment 5 Bernd Bartmann 2004-03-23 16:15:25 EST
Created attachment 98804 [details]
output of "dmesg"
Comment 6 Arjan van de Ven 2004-03-25 04:08:29 EST
are you actively using the firewire ?
Comment 7 Bernd Bartmann 2004-03-25 04:11:07 EST
I have an external SONY Firewire DVD burner connected to the system,
but it always was switched off when the system hung.
Comment 8 Bernd Bartmann 2004-04-04 06:50:52 EDT
With FC2 Test2 the lockup problems are even worse. Now the system
locks up during install time randomly. I boot from CD#1 and install
via NFS.

Is there any way to debug this problem? Serial console? 
Comment 9 Sahil Verma 2004-04-04 21:07:14 EDT
Can you boot FC2 test 1 with i8142.noaux option?

Not sure if I'm reading this right, but you have two mice? Or a KVM?
Does it boot with only a PS/2 mouse?

Does pci=noacpi help?
Comment 10 Bernd Bartmann 2004-04-05 11:06:58 EDT
I'm now on FC2 Test 2. I'll try i8142.noaux option (BTW: What this
supposed to do?)

There is only one USB mouse connected to the system. No KVM switch.

I already tried all these acpi/apm options to no avail.
Comment 11 Sahil Verma 2004-04-05 13:26:06 EDT
Whoops, I must be blind, that's i8042.noaux.

Your dmesg says so, and from Documentation/kernel-parameters.txt:

'[HW] Don't check for auxiliary (== mouse) port'

Can you boot with a PS/2 mouse, instead of USB?
Comment 12 Bernd Bartmann 2004-04-07 11:01:19 EDT
Now with only a PS/2 mouse connected this system just locked up again.
Comment 13 Alan Cox 2004-05-03 16:59:49 EDT
Was the box stable with older Linux ?
Comment 14 Bernd Bartmann 2004-05-04 03:04:34 EDT
I had RHL9 on it and never had a problem with it. I didn't test FC1 on
this system.
Comment 15 Dave Jones 2004-06-14 19:35:38 EDT
how are things looking with the final release & update kernel ?
any improvement ?
Comment 16 Bernd Bartmann 2004-06-19 08:00:33 EDT
The system now runs kernel-2.6.6-1.435 and it looks like a really big
improvement compared to all the FC2-Test versions. I haven't seen a
lock-up yet since kernel-2.6.6-1.435 is out.
Comment 17 Arjan van de Ven 2004-06-19 08:17:44 EDT
ok time to close this out then... 

Note You need to log in before you can comment on or make changes to this bug.