This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 115735 - kudzu in FC2 Test1 sometimes hangs
kudzu in FC2 Test1 sometimes hangs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 11:00 EST by Bernd Bartmann
Modified: 2014-03-16 22:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 14:39:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-02-15 11:00:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Running FC2 Test1 now since 2 days on my test system today I had kudzu
hanging twice during system startup.

The system seems to respond to keyboard input, but the bootup process
does not go on.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. wait for kudzu to hang
2.
3.
    

Additional info:
Comment 1 Bill Nottingham 2004-02-15 22:51:57 EST
Can you get a strace/backtrace?
Comment 2 Bernd Bartmann 2004-02-16 04:50:56 EST
You mean when starting kudzu manually? Will try so.
Comment 3 Miguel Dardenne 2004-04-08 09:52:32 EDT
Samt thing here with FC2test2. Booting stops at 'updating /etc/fstab',
just after 'staring kudzu'. It does not happen when skipping kudzu.

Will try to start it manually and see what it does.
Comment 4 Miguel Dardenne 2004-04-08 11:50:50 EDT
It really is not kudzu that is the issue for me. It works fine, but
updfstab makes the boot process stop.

What seems weird to me is that running updfstab from the command line
works just fine.

I wonder if that could be related to a SELinux issue, that would
prevent the script from updating fstab.
Comment 5 Bill Nottingham 2004-04-08 12:27:01 EDT
Maybe. A strace of it when it hangs would be nice.
Comment 6 Miguel Dardenne 2004-04-08 13:15:11 EDT
SELinux is definitely involved here, because SELINUX=disabled in
/etc/sysconfig/selinux now makes kudzu detect all my hardware at boot
time.

The problem is that it still hangs the boot process, maybe when
running updfstab, but since kudzu fils the boot screen with blue, I
can't see what is causing the problem now.

Again, running them from command line works smoothly.

So, i'll try to strace them from the boot script, but I make no
promise for the result, since FC2 test2 ALWAYS breaks my ext2
partition when rebooting. Then fsck, 2 reboots, and back to normal...

FYI, I updated kernel to 2.6.5 and kudzu to latest up2date version and
it does the same.
Comment 7 Miguel Dardenne 2004-04-08 13:38:41 EDT
sorry for mistake, upgrading kernel and kudzu DID solve the problem.

(And the ext2 breaking at reboot was due to label in /etc/fstab,
changing it to device file solved it.)

Now I guess downgrading to get the strace is not needed anymore then...
Comment 8 Bill Nottingham 2004-04-08 14:39:27 EDT
Marking as fixed in rawhide, then.
Comment 9 Ivo Sarak 2004-04-28 16:51:01 EDT
Is this the same issue?:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121859

Note You need to log in before you can comment on or make changes to this bug.