Bug 115740 - psutils doesn't set output paper size
psutils doesn't set output paper size
Product: Fedora
Classification: Fedora
Component: psutils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-02-15 11:31 EST by Jonathan Kamens
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 19:57:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
A file that has problems when printed 2-up. (21.89 KB, application/pdf)
2007-01-07 23:43 EST, Penelope Fudd
no flags Details
two-page document on letter paper (19.26 KB, application/postscript)
2007-07-12 23:45 EDT, Jonathan Kamens
no flags Details
psnup output that should be legal size but isn't (21.51 KB, application/postscript)
2007-07-12 23:47 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2004-02-15 11:31:42 EST
If you use psnup with -p and -P (or -w/-h and -W/-H) to generate
output onto a different page size then the input pages, it doesn't
insert any PostScript code into the resulting n-up file to tell the
printer the size of the actual printed page.  As a result, the
generated n-up file doesn't print properly.  For example, if you lay
out two letter pages on a legal page, the printer thinks the output is
letter and it is thus truncated.
Comment 1 Bill Nottingham 2006-08-07 21:49:43 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 2 Jonathan Kamens 2006-09-03 03:19:06 EDT
I'm pretty sure this hasn't been fixed.
Comment 3 Jitka Kozana 2006-09-04 06:30:12 EDT
Tried to reproduce your bug with


I tried different sizes of input/output paper and it works for me without any problems.
Could you please send me the file, that was printed incorrectly, and the command you used? 
Thank you.
Comment 4 Adam Tkac 2006-10-27 08:33:13 EDT
please, could you reproduce this bug with latest version of psutils (psnup)??

Comment 5 Penelope Fudd 2007-01-07 22:43:18 EST
Hi... I'm having a related problem; psnup is producing wrong-sized output.

Try this:

cd /usr/share/ghostscript/8.15/examples/
psmerge -o/tmp/out.ps tiger.eps tiger.eps
psnup -2 /tmp/out.ps > /tmp/out2.ps
kghostview /tmp/out2.ps
Comment 6 Penelope Fudd 2007-01-07 23:38:19 EST
That was with FC6, psutils-1.17-26.1, ghostscript-8.15.3-1.fc6, and
kdegraphics-3.5.5-0.1.fc6 (kghostview).   You can also view the problem with
evince-0.6.0-6.fc6 or gv-3.6.2-2.fc6.

On the bright side, if you print it (cups-1.2.7-1.5.fc6), you can see more (but
not all) of the picture.  I'm using an HP PSC 2175 all-in-one, with
hplip-1.6.10-1.fc6.4 and hpijs-1.6.10-1.fc6.4.

I'm attaching a 2-page pdf file that I told xpdf (xpdf-3.01-28.fc6) to print to
a file (in.ps), then I ran 'psnup -d -2 < in.ps > out.ps' on the output and
printed it with 'lpr out.ps'.  The file looks good with gv, evince and
kghostview, but when printed, the left edge of the first page is cut off by the
1-pixel black border (which comes from using the -d option), such that you can't
read the months.
Comment 7 Penelope Fudd 2007-01-07 23:43:21 EST
Created attachment 145026 [details]
A file that has problems when printed 2-up.

Print this to a file (in.ps), then 'psnup -d -2 < in.ps > out.ps' and 'lpr

The months will be cut off the left side of the first page, but the border will
be visible all the way around.	Problem not visible in gv, evince or
Comment 8 Martin Bacovsky 2007-02-15 09:36:13 EST
This seems to be problem with default paper size. Try to psnup with theese params
'psnup -d -2 -pA4 < in.ps > out.ps' put paper format you use in place of A4.
Allowed formats you can find in 'man psnup'. Also some printers have unprintable
space 3 to 7mm at the bottom of the page. To avoid this you can use -m5mm param
to  add some extra margin to your page. 

In case this didn't help, can you provide me output of 'locale|grep LC_PAPER'
and paper format you use in your printer?
Comment 9 Penelope Fudd 2007-03-30 06:30:45 EDT
Hi; it didn't help.


Comment 10 Martin Bacovsky 2007-03-30 11:52:42 EDT
Hi, I would also need to know paper size you use in your printer to get some clue.

When I try to produce out.ps as you described in comment #7 I can see in
kghostview page with content shifted to its left border. When I print this on
printer. Unprintable area is also situated on bottom of the page (left on
landscape) so I lose part of months.

Is behaviour in your case the same? 
Is your page centred on the paper (space between frame and page border is same
on left and right sides)?

Comment 11 Jonathan Kamens 2007-07-12 23:45:45 EDT
Created attachment 159120 [details]
two-page document on letter paper

Sample PostScript file for exhibiting the problem.  Two pages, letter paper.
Comment 12 Jonathan Kamens 2007-07-12 23:47:40 EDT
Created attachment 159121 [details]
psnup output that should be legal size but isn't

The file numbers2.ps is the output of "psnup -plegal -Pletter -2 numbers.ps". 
If you load this file into gv, gv displays it as letter size.  If psnup were
doing its job properly, it would be putting stuff in the header to tell gv that
it's legal.
Comment 13 Bug Zapper 2008-04-03 11:32:07 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 14 Bug Zapper 2008-05-06 19:57:55 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.