Bug 115742 - SDL causes FPU errors
SDL causes FPU errors
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 11:35 EST by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 16:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-02-15 11:35:02 EST
Description of problem:

Most DRI apps won't run with FC2-test1. (eg cube, gl-117). All of them
give segfaults and or FPU errors. No kernel traces to go with it and
it looks like its just miscompiles. 

Hardware: Radeon 9100Pro 128Mb
Comment 1 Alan Cox 2004-02-15 11:57:45 EST
Turns out its the SDL library causing the faulting - seems SDL alsa
mishandles the "no soundcard" case in our current build and our update
path can't work out how to migrate OSS audio yet
Comment 2 Thomas Woerner 2004-02-18 10:27:11 EST
I can not reproduce this.. cube is working for me without any problems.

I'd need more information:
- Do you have no soundcard?
- If no: Which one and which modules are you using for it?
Comment 3 Alan Cox 2004-02-18 10:41:15 EST
I set it up with no soundcard initially (that breaks) then with ALSA
cs46xx drivers (which stop it breaking)

Alan
Comment 4 Alan Cox 2004-02-18 10:41:48 EST
(Intel Celery 800)
Comment 5 Alan Cox 2004-05-21 16:27:21 EDT
Cant duplicate in FC2 final

Note You need to log in before you can comment on or make changes to this bug.