Bug 115753 - Regression of i810 problems
Regression of i810 problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 121942 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 13:49 EST by Mary Ellen Foster
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 6.8.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 16:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log file describing server lockup (57.64 KB, text/plain)
2004-03-13 17:09 EST, George H. Fisher
no flags Details

  None (edit)
Description Mary Ellen Foster 2004-02-15 13:49:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
I recently installed the latest Fedora update of XFree86. I'm now seeing symptoms similar to those I used to see way back with Redhat 9's initial XFree86 version: any time I switch to a text console (via ctrl-alt-FX or shutting down the system, for instance), the screen goes swirly and weird. Switching back to X after this has happened works fine.

I'm convinced this is related to the XFree86 update; I hadn't seen these symptoms until I installed the new version of X.

I can't currently locate a page describing these exact symptoms, but I remember this was a problem with the initial RH9 XFree86 that then got fixed by an update.

Here's the spec of my video card (from XF86Config):

Section "Device"
	Identifier  "Videocard0"
	Driver      "i810"
	VendorName  "Videocard vendor"
	BoardName   "Intel 830"
EndSection

Version-Release number of selected component (if applicable):
XFree86-4.3.0-55

How reproducible:
Always

Steps to Reproduce:
1. Boot computer in runlevel 5
2. Ctrl-alt-F1 to get to a virtual text console -- screen goes psychedelic
3. Ctrl-alt-F7 to get back to X, which is still happy

Actual Results:  Screen goes screwy on switching to text console

Expected Results:  Should give me a virtual console

Additional info:
Comment 1 George H. Fisher 2004-03-13 17:09:39 EST
Created attachment 98517 [details]
X log file describing server lockup
Comment 2 George H. Fisher 2004-03-13 17:14:27 EST
In my attachment of the X log file, I show how the recently "upgraded"
version of XFree86 locks up the machine every single time on bootup,
without fail.  I have had to switch to run level 3, in which case
entering startx as a user starts X with no problems.  This is with the
onboard intel video chipset i845 using the i810 driver.  In my view
the severity of this bug is "high" and not normal since this is a very
common hardware configuration on many motherboards.
Comment 3 Mike A. Harris 2004-05-05 11:53:58 EDT
The latest rawhide kernel has i8xx DRM fixes which are believed
may resolve this issue.  Details can be found in bug #119311.  Please
test Fedora Core 2 test3 fully updated with the latest rawhide updates,
and see if the problem is resolved for you with this new kernel or not.

Setting bug status to "MODIFIED" pending user testing.  Please change
status to "RAWHIDE" if the problem is resolved now, or back to
"ASSIGNED" if it persists.
Comment 4 Mike A. Harris 2004-05-05 11:57:36 EDT
*** Bug 121942 has been marked as a duplicate of this bug. ***
Comment 5 Marius Andreiana 2005-08-19 16:27:26 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to "CURRENTRELEASE", however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Another recent bug report about i810 and display problems is 157645, but doesn't
seem a duplicate of this (maybe that's the effect of DRM fixes referenced here)
Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.