Bug 115774 - rpm displays wrong summary/description of RPM if LC_ALL <> C
rpm displays wrong summary/description of RPM if LC_ALL <> C
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 18:48 EST by Thomas Ribbrock
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-15 22:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Ribbrock 2004-02-15 18:48:03 EST
Description of problem:
Under certain circumstances (see "Steps to Reproduce"), rpm will
ignore the summary and description given in a RPM file and display
another one instead. It does display the correct description if LC_ALL=C.

This is WRONG. rpm should always give priority to what's actually
stored in the RPM file and should under no circumstances try to
second-guess the packager.

NOTE: The examples use the output from a mutt RPM that will later be
published on http://www.ribbrock.org/muttix as part of the Mutt RPM
Team effort.


Version-Release number of selected component (if applicable):
rpm-4.2.1-0.30

How reproducible:
Every time

Steps to Reproduce:
1. Build an RPM that has the same name as a RPM supplied by Fedora
Core (e.g. mutt)
2. Use an LC_ALL setting that is not "C" (I've tried en_GB.UTF-8,
en_GB and en_US)
3. run "rpm -qip NEWPACKAGE.rpm"
4.  rpm will now display the description that is stored in
/usr/share/locale/SOMEWHERE/LC_MESSAGES/redhat-dist.mo and NOT the
description that is stored in the RPM file.
5. To get the correct result, run "env LC_ALL=C rpm -qip ....." instead.
  
Actual results:
esme:1.4.2.1 597> rpm -qip mutt-1.4.2.1i-1.cfp.fc1.i386.rpm 
Name        : mutt                         Relocations: (not relocateable)
Version     : 1.4.2.1i                          Vendor: "Mutt RPM
Team" <mutt-rpm@mutt.justpickone.org>
Release     : 1.cfp.fc1                     Build Date: Sun 15 Feb
2004 23:45:11 CET
Install Date: (not installed)               Build Host: esme.ribbrock.org
Group       : Applications/Internet         Source RPM:
mutt-1.4.2.1i-1.cfp.fc1.src.rpm
Size        : 3826624                          License: GPL
Signature   : (none)
Packager    : Thomas Ribbrock <emgaron@gmx.net>
URL         : http://www.mutt.org/
Summary     : A text mode mail user agent.
Description :
Mutt is a text-mode mail user agent. Mutt supports color, threading,
arbitrary key remapping, and a lot of customization.

You should install mutt if you have used it in the past and you prefer
it, or if you are new to mail programs and have not decided which one
you are going to use.
e

Expected results:
esme:1.4.2.1 598> env LC_ALL=C rpm -qip mutt-1.4.2.1i-1.cfp.fc1.i386.rpm 
Name        : mutt                         Relocations: (not relocateable)
Version     : 1.4.2.1i                          Vendor: "Mutt RPM
Team" <mutt-rpm@mutt.justpickone.org>
Release     : 1.cfp.fc1                     Build Date: Sun Feb 15
23:45:11 2004
Install Date: (not installed)               Build Host: esme.ribbrock.org
Group       : Applications/Internet         Source RPM:
mutt-1.4.2.1i-1.cfp.fc1.src.rpm
Size        : 3826624                          License: GPL
Signature   : (none)
Packager    : Thomas Ribbrock <emgaron@gmx.net>
URL         : http://www.mutt.org/
Summary     : The Mutt Mail User Agent
Description :
Mutt is a small but very powerful full-screen Unix mail client. Features
include MIME, POP3, multiple mailbox formats, colour, message threading,
scoring, GPG/PGP support and bindable keys.


Mutt was compiled against ncurses
and the following options were enabled:
 --enable-pop
   POP3 support

 --enable-imap
   IMAP support

 --with-sgid
   Set group ID - that way mutt should work with the default
permissions on
   /var/spool/mail

 --enable-compressed
   compressed folder support - gzip and bzip2

 --with-ssl
   secure transport support

 full NLS support - all message catalogs are installed.

The following patches/additions were applied:
- compressed folder patch from Roland Rosenfeld <roland@spinnaker.de>
- patch to add compressed folder settings to /etc/Muttrc
- A sample muttrc with colors enabled is supplied in
/usr/share/doc/mutt-1.4.2.1i/samples.
- Two scripts were added:
  * cmutt - starts mutt with TERM set so that colours are displayed
  * xmutt - runs mutt in an xterm or rxvt


Additional info:
Comment 1 Jeff Johnson 2004-02-15 22:38:57 EST
No. rpm should use what is in specspo for Description/Summary/Group.

That has been the behavior of rpm since RHL 6.2, and is not going to
change.

Uninstall the specspo package if you want rpm to use the
information in packages.
Comment 2 Thomas Ribbrock 2004-02-16 02:30:54 EST
I have not noticed this behaviour on older RHL's (though I never went
beyond RHL 7.3). Quite the contrary, on those RHL's, rpm *did* produce
the correct output. I do not oncur with the statement that this is the
correct behaviour - when the packager adds some description to a
package, this is what should be displayed, as the packages knows best
what's in a package. I regard this as a bug.
At the very least, rpm should displaya message that this is not the
correct description of the package but second-guessed due to policies
of the distro and give an option to display the correct description.

Note You need to log in before you can comment on or make changes to this bug.