Bug 115788 - Latex2html unable to produce images
Latex2html unable to produce images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
mitgcm.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 01:39 EST by Ed Hill
Modified: 2015-03-04 20:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 13:08:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Hill 2004-02-16 01:39:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031031 Galeon/1.3.10

Description of problem:
Using tetex-2.0.2-11 with Fedora Core 2 test 1, latex2html fails to 
build images (equations) and gives errors of the form:

 Error while converting image
 Converting image #1350
 pstoimg: Error: "/usr/bin/ppmquant -floyd 256 <
/tmp/l2h5687/p18531.pnm | /usr/bin/pnmtopng -interlace -trans
'#ffffff'  > img1350.png" failed: Bad file descriptor

The same exact commands in a RH 9 install (w/ tetex-1.0.7-66) work
with no problems (see: mitgcm.org/pelican/).  So it seems that the
newer FC2-t1 tetex package lacks the functionality of the older RH9
packages.

Version-Release number of selected component (if applicable):
tetex-2.0.2-11

How reproducible:
Always

Steps to Reproduce:
1. get the MITgcm LaTeX manual from: mitgcm.org
2. build it
3. watch as latex2html fails to produce images
    

Additional info:
Comment 1 Sammy 2004-02-16 20:09:12 EST
I have perhaps the same/similar problem. While translating a latex file, which 
took a very long time (unusually long!) the image creation failed by saying 
that tex ran out of resources. On a 1.5GB ram system this indicates some 
kind of a problem. 
Comment 2 Ed Hill 2004-02-16 20:18:57 EST
I'd like to clarify the problem I reported earlier.  I think it has
nothing to do with memory allocation since LaTeX (from the tetex
package) has no problem producing DVI output for my LaTeX files.  What
does *consistently* fail for me is all the image production within
latex2html (where most of the images are produced to represent
equations).  The errors are "Bad file descriptors" as shown above.

I'm currently trying to sort out the differences between the tetex
package as shipped with RH9 and tetex in Fedora Core.
Comment 3 Tim Waugh 2004-02-17 07:34:32 EST
What happens if you downgrade netpbm-progs to the version from Fedora
Core 1?
Comment 4 Ed Hill 2004-02-17 10:04:52 EST
OK, I downgraded both of the FC2 netpbm pacages to the FC1 versions:

  netpbm-9.24-12, netpbm-progs-9.24-12

and now the latex2html translation works just fine!  Thank you!!!
So I wonder whats broken in the latest netpbm RPMs?
Comment 5 Phil Knirsch 2004-02-17 10:31:49 EST
Interessting. I'll go and check the pipe you ran and see where and why
it exactly fails.

Read ya, Phil

PS: Reassigning to me, Tim, as this seems to be my problem. :-)
Comment 6 Phil Knirsch 2004-02-17 13:08:05 EST
OK, found and fixed the problem. pnmquant was doing the command line
parsing wrongly.

New netpbm-10.19-6 and later contain a fix. Should hit development in
the next few days.

Read ya, Phil
Comment 7 Tim Keitt 2004-06-01 01:28:38 EDT
This still occurs with netpbm-10.19-7. Do I need the FC2 rpms?
Comment 8 Tim Keitt 2004-06-01 01:31:16 EDT
Shoot, I was logged in elsewhere -- I was using an FC2 box with
netpbm-10.19-7 installed and the problem is there (same error message).
Comment 9 Tim Keitt 2004-06-21 17:50:42 EDT
This still does not work after downgrading to the FC1 netpbm packages
(9.24-12). I get the same "bad file descriptor" error. The most recent
FC2 packages do not work either. I really need this to work right now!
Comment 10 Ed Hill 2004-06-21 22:09:09 EDT
I agree that this is a mighty annoying bug and I do wish there was a
usable latex2html in FC1 or FC2.  Or even FC3!  I tried digging into
latex2html code to discover why so many figures are mangled or missing
(as discussed above) but its a daunting task.

And while I'm not at all proud of this solution, I did setup a
complete RH 9 environment within an FC2 install using chroot:

http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html_single/Multi-Distro-Dev.html

and am using that as a stop-gap measure for building our
documentation.  Hopefully, latex2html in FC will improve and I can
abandon this hack.
Comment 11 Mark van Rossum 2004-09-01 06:07:03 EDT
I had a similar problem.
I had 
   libnetpbm.so -> libnetpbm.so.10.11
rather than
   libnetpbm.so -> libnetpbm.so.10.19
Fixing this solved it. This solution might be very peculiar for my case....

Try if pnmquant works on any image. 
Try also latex2html -debug or -verbosity

Note You need to log in before you can comment on or make changes to this bug.