Bug 115805 - Partition table was destroyed during install process
Partition table was destroyed during install process
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 05:11 EST by Rob Maris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-16 23:33:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Maris 2004-02-16 05:11:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) Opera 
7.23  [de]

Description of problem:
I was going to install Fedora V0.94 testversion.
The target workstation had 4 partitions, of which two were reserved 
for Windows (system; data).
It was a known problem, that the ext2 partition was damaged (Suse 
linux had been present in this partition.
I used a "bootmagic" from PowerQuest corporation as the OS-selector 
tool.
As I decided to install Fedora, Anaconda lets me select between 
automatic partition or hand partition (druid). I selected hand, in 
order to preserve current partitioning.
Then, the installer said that only one partition would be present.
I cancelled the installation.
After inspection I found out that the computer is not bootable.
Using PartitionMagic, I found out, that all the partitions are lost.

I suggest that Anaconda did not recognize the individual partition, 
because of the damage in the ext2 partition.
Later on I repeated the whole procedur:
After having defined 4 partitions again with PartitionMagic, I 
started Anaconda again. This time, all the partitions were 
recognized.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. One must have a damaged ext2 partition among one or more (FAT32) 
partitions
2. Install Fedora, using hand partitioning
3.
    

Actual Results:  (the above is the suggestion to reproduce)

Additional info:
Comment 1 Jeremy Katz 2004-02-16 23:33:43 EST
Anaconda doesn't commit any changes to the partition table this early.
 And 0.94 is old... you should use either FC1 or the more current test
release. 

Note You need to log in before you can comment on or make changes to this bug.