Bug 115808 - NoClassDefFoundException if ccm hostinit not run
NoClassDefFoundException if ccm hostinit not run
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: installation (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 05:33 EST by Steve Etherington
Modified: 2007-04-18 13:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 18:23:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Etherington 2004-02-16 05:33:04 EST
Description of problem:
The WAF installation guide says that the command 
ccm hostinit [options] should not be run when installing for 
development. However, when I install the aplaws bundle and start the 
server, I get a NoClassDefFoundException for 
com.arsdigita..BaseServlet. 

If I run ccm hostinit, then this problem is solved.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2004-02-16 06:01:22 EST
Have you added all the applications to project.xml, run
ccm-configure.sh and run 'ant deploy' ? Running 'ccm hostinit' will
not work because it will not copy any files from your development
environment.
Comment 2 Steve Etherington 2004-02-16 06:03:02 EST
yes I had carried out all those steps.
Comment 3 Dennis Gregorovic 2006-12-07 18:23:48 EST
closing old CCM bugs

Note You need to log in before you can comment on or make changes to this bug.