Bug 1158379 - perl-Crypt-Random-1.25-20.fc22 FTBFS: t/generator.t test fails sometimes
Summary: perl-Crypt-Random-1.25-20.fc22 FTBFS: t/generator.t test fails sometimes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Crypt-Random
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-29 09:24 UTC by Petr Pisar
Modified: 2014-11-10 06:29 UTC (History)
2 users (show)

Fixed In Version: perl-Crypt-Random-1.25-21.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-10 06:29:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CPAN 99880 None None None Never

Description Petr Pisar 2014-10-29 09:24:55 UTC
perl-Crypt-Random-1.25-20.fc22 fails to build in F22 because a test fails sometimes:

+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
# Test 9 got: "0" (t/generator.t at line 26 fail #2)
#   Expected: "1"
#  t/generator.t line 26 is:     ok($x != $y, 1);
t/generator.t ........ 
Failed 1/18 subtests 

The test actually compares two random numbers and fails if the numbers are equalled. It's natural that you can sometimes get two same numbers from a random number generator. The test is faulty by design.

Comment 1 Fedora Update System 2014-10-29 11:56:40 UTC
perl-Crypt-Random-1.25-21.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/perl-Crypt-Random-1.25-21.fc21

Comment 2 Paul Howarth 2014-10-29 11:59:46 UTC
I patched the test to make it a TODO test for now.

Comment 3 Fedora Update System 2014-10-31 01:28:07 UTC
Package perl-Crypt-Random-1.25-21.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Crypt-Random-1.25-21.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13994/perl-Crypt-Random-1.25-21.fc21
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-11-10 06:29:15 UTC
perl-Crypt-Random-1.25-21.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.