Bug 1158470 - [ga][windows][sso] SSO not working: WindowsError: [Error 5] Access is denied
Summary: [ga][windows][sso] SSO not working: WindowsError: [Error 5] Access is denied
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On: 1166748
Blocks: 1124263
TreeView+ depends on / blocked
 
Reported: 2014-10-29 13:01 UTC by Jiri Belka
Modified: 2015-02-12 14:19 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-12 14:19:01 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34635 master MERGED win32: OpenKey third parameter must always be 0 Never
oVirt gerrit 35163 master MERGED win32: Set registry value with SetValueEx not SetValue Never
oVirt gerrit 35257 ovirt-3.5 MERGED win32: OpenKey third parameter must always be 0 Never
oVirt gerrit 35259 ovirt-3.5 MERGED win32: Set registry value with SetValueEx not SetValue Never

Description Jiri Belka 2014-10-29 13:01:24 UTC
Description of problem:

tested with 3.5.5 and 3.5.6

Dummy-2::INFO::2014-10-29 12:23:27,102::ovirtagentlogic::270::root::Received an external command: login...
Dummy-2::ERROR::2014-10-29 12:23:27,102::guestagentwin32::249::root::Error occurred during user login.
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 234, in login
  File "GuestAgentWin32.pyc", line 225, in _performSAS
  File "GuestAgentWin32.pyc", line 208, in _setSoftwareSASPolicy
WindowsError: [Error 5] Access is denied


Version-Release number of selected component (if applicable):
3.5.5/3.5.6

How reproducible:
100%

Steps to Reproduce:
1. 64bit windows 7 with WGT installed (sso component installed)
2. add OS into AD, login as AD user via User Portal
3.

Actual results:
doesn't work

Expected results:
should work

Additional info:
~~~


Dummy-1::INFO::2014-10-29 08:57:37,187::ovirtguestservice::80::root::Starting OVirt Guest Agent service
Dummy-2::INFO::2014-10-29 08:57:37,187::ovirtagentlogic::270::root::Received an external command: refresh...
Dummy-2::ERROR::2014-10-29 08:57:37,203::guestagentwin32::106::root::Error retrieving network interfaces.
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 84, in GetNetworkInterfaces
  File "win32com\client\__init__.pyc", line 95, in Dispatch
  File "win32com\client\dynamic.pyc", line 108, in _GetGoodDispatchAndUserName
  File "win32com\client\dynamic.pyc", line 85, in _GetGoodDispatch
com_error: (-2147221008, 'CoInitialize has not been called.', None, None)
Dummy-2::ERROR::2014-10-29 08:57:37,203::guestagentwin32::506::root::Failed to retrieve disk mapping
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 497, in getDiskMapping
  File "win32com\client\__init__.pyc", line 95, in Dispatch
  File "win32com\client\dynamic.pyc", line 108, in _GetGoodDispatchAndUserName
  File "win32com\client\dynamic.pyc", line 85, in _GetGoodDispatch
com_error: (-2147221008, 'CoInitialize has not been called.', None, None)
Dummy-2::INFO::2014-10-29 08:57:47,171::ovirtagentlogic::270::root::Received an external command: api-version...
Dummy-2::INFO::2014-10-29 08:57:47,171::ovirtagentlogic::109::root::API Version updated from 0 to 1
Dummy-1::INFO::2014-10-29 09:06:34,765::ovirtguestservice::94::root::Stopping OVirt Guest Agent service
Dummy-1::INFO::2014-10-29 09:07:11,046::ovirtguestservice::80::root::Starting OVirt Guest Agent service
Dummy-1::INFO::2014-10-29 09:09:13,703::ovirtguestservice::94::root::Stopping OVirt Guest Agent service
Dummy-1::INFO::2014-10-29 10:13:38,265::ovirtguestservice::80::root::Starting OVirt Guest Agent service
Dummy-2::INFO::2014-10-29 10:13:38,390::ovirtagentlogic::270::root::Received an external command: refresh...
Dummy-2::ERROR::2014-10-29 10:13:38,515::guestagentwin32::106::root::Error retrieving network interfaces.
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 84, in GetNetworkInterfaces
  File "win32com\client\__init__.pyc", line 95, in Dispatch
  File "win32com\client\dynamic.pyc", line 108, in _GetGoodDispatchAndUserName
  File "win32com\client\dynamic.pyc", line 85, in _GetGoodDispatch
com_error: (-2147221008, 'CoInitialize has not been called.', None, None)
Dummy-2::ERROR::2014-10-29 10:13:38,515::guestagentwin32::506::root::Failed to retrieve disk mapping
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 497, in getDiskMapping
  File "win32com\client\__init__.pyc", line 95, in Dispatch
  File "win32com\client\dynamic.pyc", line 108, in _GetGoodDispatchAndUserName
  File "win32com\client\dynamic.pyc", line 85, in _GetGoodDispatch
com_error: (-2147221008, 'CoInitialize has not been called.', None, None)
Dummy-2::INFO::2014-10-29 10:13:48,015::ovirtagentlogic::270::root::Received an external command: api-version...
Dummy-2::INFO::2014-10-29 10:13:48,015::ovirtagentlogic::109::root::API Version updated from 0 to 1
Dummy-2::INFO::2014-10-29 11:32:47,269::ovirtagentlogic::270::root::Received an external command: login...
Dummy-2::ERROR::2014-10-29 11:32:47,269::guestagentwin32::249::root::Error occurred during user login.
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 234, in login
  File "GuestAgentWin32.pyc", line 225, in _performSAS
  File "GuestAgentWin32.pyc", line 208, in _setSoftwareSASPolicy
WindowsError: [Error 5] Access is denied
Dummy-1::INFO::2014-10-29 11:44:02,921::ovirtguestservice::94::root::Stopping OVirt Guest Agent service
Dummy-1::INFO::2014-10-29 11:44:31,280::ovirtguestservice::80::root::Starting OVirt Guest Agent service
Dummy-2::INFO::2014-10-29 11:45:42,947::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 11:45:42,947::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 11:45:42,947::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 11:45:42,947::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 11:45:42,947::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 11:45:42,947::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 11:45:42,947::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 11:45:42,947::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 11:45:42,947::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 11:45:42,947::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 11:45:51,250::ovirtagentlogic::270::root::Received an external command: login...
Dummy-2::ERROR::2014-10-29 11:45:51,250::guestagentwin32::249::root::Error occurred during user login.
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 234, in login
  File "GuestAgentWin32.pyc", line 225, in _performSAS
  File "GuestAgentWin32.pyc", line 208, in _setSoftwareSASPolicy
WindowsError: [Error 5] Access is denied
Dummy-2::INFO::2014-10-29 12:23:05,132::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 12:23:05,132::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 12:23:05,132::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 12:23:05,132::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 12:23:05,132::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 12:23:05,132::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 12:23:05,132::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 12:23:05,132::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 12:23:05,132::ovirtagentlogic::270::root::Received an external command: lock-screen...
Dummy-2::ERROR::2014-10-29 12:23:05,132::guestagentwin32::351::root::LockWorkStation exception
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 321, in LockWorkStation
error: (1008, 'WTSQueryUserToken', 'An attempt was made to reference a token that does not exist.')
Dummy-2::INFO::2014-10-29 12:23:08,618::ovirtagentlogic::270::root::Received an external command: login...
Dummy-2::ERROR::2014-10-29 12:23:08,618::guestagentwin32::249::root::Error occurred during user login.
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 234, in login
  File "GuestAgentWin32.pyc", line 225, in _performSAS
  File "GuestAgentWin32.pyc", line 208, in _setSoftwareSASPolicy
WindowsError: [Error 5] Access is denied
Dummy-2::INFO::2014-10-29 12:23:27,102::ovirtagentlogic::270::root::Received an external command: login...
Dummy-2::ERROR::2014-10-29 12:23:27,102::guestagentwin32::249::root::Error occurred during user login.
Traceback (most recent call last):
  File "GuestAgentWin32.pyc", line 234, in login
  File "GuestAgentWin32.pyc", line 225, in _performSAS
  File "GuestAgentWin32.pyc", line 208, in _setSoftwareSASPolicy
WindowsError: [Error 5] Access is denied
~~~

Comment 2 Sandro Bonazzola 2014-11-21 08:57:52 UTC
Vinzenz, can you fill the doctext or mark this ad doctext not needed?

Comment 3 Vinzenz Feenstra [evilissimo] 2014-11-24 07:43:50 UTC
(In reply to Sandro Bonazzola from comment #2)
> Vinzenz, can you fill the doctext or mark this ad doctext not needed?

Does not require doc text since this bug was never released

Comment 4 Jiri Belka 2014-11-24 08:47:42 UTC
ok, vt11 / 3.5.7 and w7 64bit.


Note You need to log in before you can comment on or make changes to this bug.