Bug 115897 - evolution crashes when lanched with a segmentation fault
Summary: evolution crashes when lanched with a segmentation fault
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-16 22:19 UTC by Don Hardaway
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-07-08 12:35:33 UTC


Attachments (Terms of Use)
Strace of evolution crash (last portion) (23.82 KB, text/plain)
2004-02-23 20:30 UTC, Mace Moneta
no flags Details
addressbook-sources.xml that worked (224 bytes, text/plain)
2004-03-06 18:03 UTC, P Jones
no flags Details

Description Don Hardaway 2004-02-16 22:19:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
Application "evolution" (process 2393) has crashed
due to a fatal error.
(Segmentation fault)

Version-Release number of selected component (if applicable):
evolution-1.5.3-1,  kernel-2.6.2-1.81

How reproducible:
Always

Steps to Reproduce:
1.launch evolution
2.
3.
    

Actual Results:  it crashes

Expected Results:  it works

Additional info:

Application "evolution" (process 2393) has crashed
due to a fatal error.
(Segmentation fault)

Comment 1 Mace Moneta 2004-02-19 18:53:17 UTC
I'm seeing this here too.  Evolution simply will not start after the
initial configuration.  

Steps to Reproduce:
1. Add a new userid
2. Run evolution on the new userid
3. Respond to the configuration questions (simple local delivery/SMTP
config)
4. Click Apply when prompted to save the configuration
5. Segfault
6. All subsequent attempts to run Evolution segfault.

Comment 2 Don Hardaway 2004-02-20 16:12:14 UTC
I am still having the problem with the latest updates kernel-2.6.3-1.91.

Comment 3 Mace Moneta 2004-02-23 20:30:58 UTC
Created attachment 97959 [details]
Strace of evolution crash (last portion)

Comment 4 P Jones 2004-03-02 23:30:27 UTC
I get this too.   It seems to be at the end of a dialog that says
something about migrating evolution/addressbook-sources.xml (There or
not).

Comment 5 P Jones 2004-03-06 18:03:04 UTC
Created attachment 98344 [details]
addressbook-sources.xml that worked

addressbook-sources.xml

Comment 6 P Jones 2004-03-06 18:03:59 UTC
I found that I could get past this with a diffrent
addressbook-sources.xml file in ~/evolution.


Note You need to log in before you can comment on or make changes to this bug.