Bug 11591 - Apparent syntax error in /etc/rc.d/init.d/network
Apparent syntax error in /etc/rc.d/init.d/network
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
: 11062 11603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-23 00:28 EDT by Ian Mortimer
Modified: 2014-03-16 22:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-26 08:14:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2000-05-23 00:28:14 EDT
Line 72 of /etc/rc.d/init.d/network (initscripts-5.00-1) reads:

   [ "${gateway}" != "${gateway##[0-9}" ] && \

This looks wrong.  I'm guessing it should be:

   [ "${gateway}" != "${gateway##[0-9]}" ] && \


Ian
Comment 1 Michael Tokarev 2000-05-26 08:13:59 EDT
*** Bug 11603 has been marked as a duplicate of this bug. ***
Comment 2 Michael Tokarev 2000-05-26 08:14:59 EDT
See also my comments for bug 11603
(http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=11603)
Comment 3 Bill Nottingham 2000-05-31 17:19:28 EDT
Shoud be fixed in initscripts-5.14.
Comment 4 Bill Nottingham 2000-05-31 18:43:48 EDT
*** Bug 11062 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.