Bug 115981 - c.a.cms.PublishedLink class is not closing data query cursors
c.a.cms.PublishedLink class is not closing data query cursors
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Li
Jon Orris
:
Depends On:
Blocks: 113496
  Show dependency treegraph
 
Reported: 2004-02-17 08:42 EST by Daniel Berrange
Modified: 2007-04-18 13:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 15:58:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2004-02-17 08:42:39 EST
Description of problem:
The c.a.cms.PublishedLink#updateLiveLinksFromCollection method does
not appear to be closing cursors correctly.

2004-02-17 13:44:30,855 [lizer] INFO  rdbms.ResultCycle - The
ResultSet was created at: 
java.lang.Throwable
        at
com.redhat.persistence.engine.rdbms.ResultCycle.<init>(ResultCycle.java:51)
        at
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java(Compiled
Code))
        at
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:431)
        at
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:262)
        at
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:253)
        at com.redhat.persistence.Cursor.execute(Cursor.java:124)
        at com.redhat.persistence.Cursor.next(Cursor.java:108)
        at
com.arsdigita.persistence.DataQueryImpl.next(DataQueryImpl.java:465)
        at
com.arsdigita.cms.PublishedLink.updateLiveLinksFromCollection(PublishedLink.java:239)
        at
com.arsdigita.cms.PublishedLink.updateLiveLinks(PublishedLink.java:222)
        at com.arsdigita.cms.ContentItem.setLive(ContentItem.java:1209)
        at
com.arsdigita.cms.ContentItem.promotePendingVersion(ContentItem.java:1643)
        at
com.arsdigita.cms.lifecycle.PublishLifecycleListener.begin(PublishLifecycleListener.java:96)
        at
com.arsdigita.cms.lifecycle.Scheduler.fireCycleEvents(Scheduler.java:318)
        at
com.arsdigita.cms.lifecycle.Scheduler.checkAndFire(Scheduler.java:131)
        at
com.arsdigita.cms.lifecycle.Scheduler$2.excurse(Scheduler.java:202)
        at
com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
        at com.arsdigita.cms.lifecycle.Scheduler.run(Scheduler.java:198)
        at
com.arsdigita.cms.lifecycle.SchedulerTask.run(SchedulerTask.java:34)
        at java.util.TimerThread.mainLoop(Timer.java:445)
        at java.util.TimerThread.run(Timer.java:395)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create and publish a bunch of items
2. Watch the logs
3. Wait a while
  
Actual results:
Repeated messages:

2004-02-17 13:45:31,249 [lizer] WARN  rdbms.ResultCycle - ResultSet 
was not closed.  Turn on INFO logging for class
com.redhat.persistence.engine.rdbms.ResultCycle to see the stack trace
for this ResultSet.


Expected results:
No messages.

Additional info:
Comment 1 Richard Li 2004-02-24 16:47:32 EST
I can't reproduce this problem, at least, not in the simple case. I
created a few content items with images, and published them all. After
waiting for > 5 minutes, I still don't see anything in the logs about
unclosed ResultSets....

So I closed the DataCollections passed into
updateLiveLinksFromCollection @40764. Scott, I think you're familiar
with this code -- could you take a quick look at the diff to see if
there's anything I'm missing?

Note You need to log in before you can comment on or make changes to this bug.