Bug 115993 - ks=cdrom:/ks.cfg still non-functoinal
ks=cdrom:/ks.cfg still non-functoinal
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-17 10:09 EST by Chris Kloiber
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-17 16:56:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2004-02-17 10:09:28 EST
Description of problem:

Customer reports that placing ks.cfg in the root of a boot.iso cdrom
and specifying 'linux ks=cdrom:/ks.cfg' still fails with Red Hat
Enterprise Linux 3 Quarterly Update 1.

Placing the ks.cfg in the initrd and specifying 'linux file:/ks.cfg'
does still work, but is inconvienient.
Comment 2 Jeremy Katz 2004-02-17 12:15:12 EST
What type of CDROM?  (ie, IDE vs SCSI, if scsi, what controller)?
Comment 5 Mike McLean 2004-02-17 16:28:26 EST
WORKSFORME

Possible reasons for client's problem
1) Unusual cdrom driver
2) Incorrectly created custom boot.iso
3) Multiple cdrom devices?
Comment 6 Matt Barnes 2004-02-27 13:07:59 EST
The CD was made on a IDE burner (HP), and was atempted to be read 
from another (Matsushita) IDE CDROM.

After describing the problem, Chris Kloiber (ckloiber@redhat.com) was 
able to reproduce the error using CD-RW media.

However, I am able to use the 'linux ks=file:/ks.cfg' procedure with 
the kickstart file embeded in the initrd.img file.

I am creating the '.iso' file with:
mkisofs -o file.iso -b isolinux.bin -c boot.cat -no-emul-boot -boot-
load-size 4 -boot-info-table -R -J -v -T isolinux/

And I make my CD with:
cdrecord dev=0,0,0 speed=2 -pad -v -eject file.iso

Comment 7 Mike McLean 2004-02-27 15:05:23 EST
Matt's above comment answers Jeremy's question, so I am moving out of
NEEDINFO.
Comment 8 Mike McLean 2004-02-27 15:28:08 EST
Chris or Matt: Can you point me at one of these non-working kickstart
isos?  (Don't attach it, just give me a url or something.)
Comment 9 Chris Kloiber 2004-02-28 18:39:27 EST
Chris Vanhoof tried it for me, and it only worked with the ks.cfg in
the initrd, using file: rather then cdrom:. The CD-RW has been
refromatted and reused. I'm not in Raleigh at the moment, ask Chris
Vanhoof to duplicate it again please.
Comment 10 Matt Barnes 2004-03-25 07:01:06 EST
Hello,
Are there any updates to this?

Matt
Comment 11 Chris Van Hoof 2004-03-25 16:52:41 EST
Ill be testing this over the weekend.  Ill have some results late
Monday...

--chris
Comment 12 Mike McLean 2004-03-25 17:17:19 EST
I have tested this and not been able to reproduce the failure.  Others
claim to have reproduced it though.

If someone can reproduce this bug, then *please* save your boot.iso
and contact me.  (Do not attach it to the bug; just contact me and
we'll work out a way for me to get access to it.)
Comment 13 Mike McLean 2004-06-17 16:56:59 EDT
Closing due to inactivity.  If someone can reproduce this bug, then
please reopen and provide the details requested above.

Note You need to log in before you can comment on or make changes to this bug.