Bug 116070 - Changing the "Product" field gives an error message.
Changing the "Product" field gives an error message.
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.17
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-17 20:07 EST by Aleksey Nogin
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-18 02:00:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-02-17 20:07:10 EST
I tried to change bug 112207 from "Product: Bugzilla" to "Product: Red
Hat Linux" and got an error message. Unfortunatelly, I did not write
it down - I pressed back, thinking I will be able to reproduce it
later, but it turned out that the change actually succeeded (at least
up to some point).
Comment 1 Aleksey Nogin 2004-02-17 22:01:49 EST
Just tried changing the "Product" field of the bug 35236 and got:

Software error:

SELECT profiles.login_name, profiles.userid, votes.count,
products.votesperuser, products.maxvotesperbug FROM profiles LEFT JOIN
votes ON profiles.userid = votes.who LEFT JOIN bugs USING(bug_id) LEFT
JOIN products ON products.id = bugs.product_id WHERE votes.bug_id =
35236 : ERROR:  Attribute profiles.login_name must be GROUPed or used
in an aggregate function at globals.pl line 337.

For help, please send mail to the webmaster (bugzilla@redhat.com),
giving this error message and the time and date of the error. 
Comment 2 Aleksey Nogin 2004-02-17 22:09:47 EST
P.S. Not sure whether this is another side of the same problem, or a
separate one, but after I change the Product field, the "Bug Activity"
pages (https://bugzilla.redhat.com/bugzilla/show_activity.cgi?id=35236
and https://bugzilla.redhat.com/bugzilla/show_activity.cgi?id=112207
respectively) do _not_ have any mention of the product change, only
showing the corresponding component change.

P.P.S. Forgot to say in comment #2 - in bug 35236 I was changing the
Product from "Red Hat Raw Hide" to "Fedora Core" (so it probably does
not depend on the specific old/new values of the field).
Comment 3 David Lawrence 2004-02-18 02:00:08 EST
The failure in comment #1 was due to a schema change recently made.
Changing votes.count to votes.vote_count in the cgi code should fix
that  from occuring again. Anything after the offending code failed to
execute which is why the bug report was left uncompleted. Closing, but
reopen if you see this again.

Note You need to log in before you can comment on or make changes to this bug.