Bug 116109 - setexeccon(user_u:user_r:rpm_script_t) fails from context "user_u:user_r:user_t": Invalid argument
Summary: setexeccon(user_u:user_r:rpm_script_t) fails from context "user_u:user_r:user...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-18 11:23 UTC by Kaj J. Niemi
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-18 17:17:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaj J. Niemi 2004-02-18 11:23:49 UTC
Description of problem:

% sudo rpm -Fvh qt*
Password:
Preparing...               
########################################### [100%]
   1:qt                    
########################################### [  4%]
warning: setexeccon(user_u:user_r:rpm_script_t) fails from context
"user_u:user_r:user_t": Invalid argument
Continuing ...


Version-Release number of selected component (if applicable):
rpm-4.3-0.11

How reproducible:
Always

Steps to Reproduce:
1. install something
2.
3.
  
Actual results:
Software still does get installed

Additional info:
Best guess is that this is SELinux related.

Comment 1 Jeff Johnson 2004-02-18 17:17:38 UTC
Yup, this is not a bug, you need to insure that rpm is invoked
from the "sysadm_r" (or "system_r", but that's for anaconda)
role.

Invoking id will show you what role you are in "user_u:user_r:user_t".

You can change roles by doing
    newrole -r sysadm_r
There are other ways to establish "sysadm_r" role as well, including
    a) su -
    b) sudo -r sysadm_r

Comment 2 Kaj J. Niemi 2004-02-18 17:28:47 UTC
Dang.. my bad. Thanks ;-)


Note You need to log in before you can comment on or make changes to this bug.