Bug 116126 - Installer finds no harddrives (DAC960: Mylex AcceleRAID 170)
Installer finds no harddrives (DAC960: Mylex AcceleRAID 170)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 09:53 EST by Heinz Deinhart
Modified: 2014-03-16 22:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-01 22:54:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this logfile was made just before startup of anaconda (rawhide Feb-18) (4.49 KB, text/plain)
2004-02-19 03:30 EST, Heinz Deinhart
no flags Details
this patch fixes kudzu -p on my dac960 based system (1.35 KB, patch)
2004-02-25 11:36 EST, Heinz Deinhart
no flags Details | Diff
fixes dac960 detection (1.17 KB, patch)
2004-02-28 04:40 EST, Heinz Deinhart
no flags Details | Diff

  None (edit)
Description Heinz Deinhart 2004-02-18 09:53:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
On a fileserver that has only some drives on a Mylex AcceleRAID 170
controller (DAC960 driver) the Install utitlity does not find any
harddives to install to.

This happens with fedore core 2 test1 (1.90) and development/RAWHIDE
of Feb 18

This Ouput is from a 2.4.20-20.7 on a redhat 7.x system:
[root@ahab c0]# pwd
/proc/rd/c0
[root@ahab c0]# cat current_status 
***** DAC960 RAID Driver Version 2.4.11 of 11 October 2001 *****
Copyright 1998-2001 by Leonard N. Zubkoff <lnz@dandelion.com>
Configuring Mylex AcceleRAID 170 PCI RAID Controller
  Firmware Version: 7.00-03, Channels: 1, Memory Size: 32MB
  PCI Bus: 3, Device: 2, Function: 0, I/O Address: Unassigned
  PCI Address: 0xFA000000 mapped at 0xF8845000, IRQ Channel: 24
  Controller Queue Depth: 512, Maximum Blocks per Command: 2048
  Driver Queue Depth: 511, Scatter/Gather Limit: 128 of 257 Segments
  Physical Devices:
    0:0  Vendor: IBM       Model: IC35L073UCD210-0  Revision: S5BS
         Wide Synchronous at 160 MB/sec
         Serial Number:         ZNZ0Y601
         Disk Status: Online, 143339520 blocks
    0:1  Vendor: IBM       Model: IC35L073UCD210-0  Revision: S5BS
         Wide Synchronous at 160 MB/sec
         Serial Number:         ZNZ11264
         Disk Status: Online, 143339520 blocks
    0:2  Vendor: IBM       Model: IC35L073UCD210-0  Revision: S5BS
         Wide Synchronous at 160 MB/sec
         Serial Number:         ZNZ0X586
         Disk Status: Online, 143339520 blocks
    0:3  Vendor: IBM       Model: IC35L073UCD210-0  Revision: S5BS
         Wide Synchronous at 160 MB/sec
         Serial Number:         ZNZ0W554
         Disk Status: Online, 143339520 blocks
    0:5  Vendor: IBM       Model: IC35L073UCD210-0  Revision: S5BS
         Wide Synchronous at 160 MB/sec
         Serial Number:         ZNZ0Y898
    0:6  Vendor: SUPER     Model: GEM318            Revision: 0   
         Asynchronous
    0:7  Vendor: MYLEX     Model: AcceleRAID 170    Revision: 0700
         Wide Synchronous at 160 MB/sec
         Serial Number:   
  Logical Drives:
    /dev/rd/c0d0: RAID-6, Online, 25165824 blocks
                  Logical Device Initialized, BIOS Geometry: 255/63
                  Stripe Size: 64KB, Segment Size: 8KB
                  Read Cache Disabled, Write Cache Enabled
    /dev/rd/c0d1: RAID-5, Online, 392269824 blocks
                  Logical Device Initialized, BIOS Geometry: 255/63
                  Stripe Size: 64KB, Segment Size: 8KB
                  Read Cache Disabled, Write Cache Enabled
  No Rebuild or Consistency Check in Progress
[root@ahab c0]# 


Version-Release number of selected component (if applicable):
Fedora Core 1.90 and development/RAWHIDE Feb 18

How reproducible:
Always

Steps to Reproduce:

    

Actual Results:  Installer gave up, and rebootet the machine

Expected Results:  It should find the drivers and let me install FC2 test

Additional info:
Comment 1 Jeremy Katz 2004-02-18 14:25:56 EST
Can you switch to tty2 (with the rawhide tree) and run `python -c
'import kudzu; print kudzu.probe(kudzu.CLASS_HD, kudzu.BUS_UNSPEC,
0)'?  If that doesn't show anything, could you also grab the
/proc/rd/... files from there?
Comment 2 Heinz Deinhart 2004-02-19 03:30:14 EST
Created attachment 97827 [details]
this logfile was made just before startup of anaconda (rawhide Feb-18)
Comment 3 Heinz Deinhart 2004-02-19 03:36:51 EST
i did it with rawhide feb-18 and got [] back from kudzu.probe,
the proc infos are in the attachment above, some more proc files
are here:
http://www.auto.tuwien.ac.at/~heinz/fc2t1-dac960problem/
Comment 4 Heinz Deinhart 2004-02-19 03:42:39 EST
sorry, i forgot to mention this:
the fdisk output at the end of the logfile was generated with

# cd /tmp
# mknod c0d0 b 48 0
# fdisk -l c0d0
Comment 5 Heinz Deinhart 2004-02-25 11:36:38 EST
Created attachment 98045 [details]
this patch fixes kudzu -p on my dac960 based system

this patch makes kudzu -p find the harddisks (simple parsing bug)
note: i did not test it during install, because i failed to generate the
update.img correclty
Comment 6 Heinz Deinhart 2004-02-28 04:40:42 EST
Created attachment 98117 [details]
fixes dac960 detection

this patch fixes dac960 (/dev/rd/*) detecting (previous patch hat a bug)

using it and updateing "kudzu.pyc" and "_kudzumodule.so" in netstg2.img i was
able to install rawhide (2004-02-27) on my Mylex AcceleRAID 170 server!
Comment 7 Bill Nottingham 2004-03-01 22:54:13 EST
Thanks, will be in 1.1.47-1.

Note You need to log in before you can comment on or make changes to this bug.