Bug 11616 - RFE: Allow kickstart -net directive to query info if given invalid value
Summary: RFE: Allow kickstart -net directive to query info if given invalid value
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-23 21:51 UTC by Jeff Blaine
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Blaine 2000-05-23 21:51:35 UTC
In 6.0, we used to use the kickstart directive 'net --ip UNKNOWN' to
force the installer to ask the sysadmin to provide IP address
information manually as part of the kickstart.  This allowed
us to have generic kickstart floppies (we don't use DHCP
installs) to install machines from.  No need to update the ks.cfg
on the floppy for each machine or make a new floppy...

With 6.2, that still happens, but when the machine reboots after
the kickstart, it has lost all of its network config information
that was hand-entered and we then have to do a 'netconfig' and
set it all again manually.

Comment 1 Brock Organ 2000-06-12 19:02:53 UTC
verified bug ... the /etc/sysconfig/network-scripts/ifcfg-eth0 file contains the
"UNKNOWN" value from the ks file, and not the updated manually entered
information from the install itself ...

Comment 2 Michael Fulbright 2002-03-26 17:25:28 UTC
Deferred to future release.

Comment 3 Michael Fulbright 2002-05-26 18:59:36 UTC
Fixing bug status- sorry for the email.

Comment 4 Red Hat Bugzilla 2006-02-21 18:47:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.