Bug 116161 - text installer does not remember unselected programs within packages
text installer does not remember unselected programs within packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 116177 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 13:30 EST by Andrej Potokar
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 12:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Potokar 2004-02-18 13:30:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I'm trying to install Fedora Core1. I have Radeon9800Pro and due to
problems regarding drivers, I can't do a graphical install, so I tried
with text install.

It all goes well until I have to select programs within packages. I
can select/deselect packages (like System Tools group), I can select a
program within that package and press OK and the package is selected,
but if I try to deselect any package within any of the groups (that
has been previously selected or selected by me), the star for the
package dissapears, then I press OK and when I press F2 to see details
of the package, the same program I deselected earlier is still selected.

In short: I can't deselect any of the programs within packages,
whether it was selected before or accidentaly selected by me.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install from CD/DVD in linux text mode
2. Package selection
3. Can't deselect any of the selected programs within package details
(the star goes away, I press OK and then I press F2 on the same
package but the same program I deselected earlier is still selected)
    

Actual Results:  I can't deselect and of the programs within packages
(selected by installer or selected by me)

Expected Results:  I expected that the deselection of deselected would
remain saved. Instead it does not.

Additional info:

No error messages.

EPOX 8RDA+ (nforce2), AthlonXP1700+, 2x256Mb RAM (Dual Channel),
Radeon9800Pro, CD-ROM, DVD-ROM, 20Gb IBM, 120Gb Segate
Comment 1 Andrej Potokar 2004-02-18 16:07:15 EST
*** Bug 116177 has been marked as a duplicate of this bug. ***
Comment 2 Andrej Potokar 2004-02-19 01:09:58 EST
I reproduced the same bug with my notebook:
Compaq Evo N600C:
Mobile Pentium3@1.066Ghz, Mobility Radeon M6, 384Mb RAM, 30Gb HDD

When I choose installation, I choose Personal Desktop installation and
then I select Customize selection.
When custmizing selection of programs, the installer doesn't remember
any of the deselected programs in details (F2) whether they were
selected by the installer or previously selected by me.
Comment 3 Andrej Potokar 2004-02-19 07:10:40 EST
Same bug is present in Fedora Core 1.90 Test1.
Comment 4 Adam D. Ligas 2004-05-26 15:35:44 EDT
Reproduced the bug with my i586 router box.

Bug is present in Fedora Core 2 as well.

Tried to change version to 2, but bugzilla doesn't like me :).
Comment 5 Chris Rainey 2004-06-04 20:46:42 EDT
Same here with Fedora Core 2 on stock/standard X86 tower pc's using
netstg2.img.

Additionally during Text mode install:

1. Not allowed to 'Change Boot Order' to avoid having Grub install to
the MBR of an incorrect drive(i.e. SCSI/IDE combo where BIOS switches
to SDA on boot as first-disk, yet Grub installs to MBR of IDE
drive(ASUS P2B-S using aic7xxx controller)).  This is not a problem
with the Graphical install since you are given this option to change
boot-order from the Advanced screen of the Boot Loader section.

2.  Not allowed to remove the entry of a non-booting NTFS/DOS
partition during Grub menu edit section.  This, also, is allowed in
the Graphical system.

Obviously, I prefer the Text-Mode install since it takes less time
over FTP to load and I am faster at keyboard.

I will open additional bugs for these two items.
Comment 6 Jeremy Katz 2004-10-05 12:02:10 EDT
This should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.