Bug 116204 - Dell 1600c crash with 2.4.21-9 kernel
Dell 1600c crash with 2.4.21-9 kernel
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 19:18 EST by Curtis Stuart
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 20:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Curtis Stuart 2004-02-18 19:18:19 EST
Description of problem:
System will become unresponsive, and will have to have power cycled 
before it will come back online. This only seems to happen after the 
2.4.21-9smp boot on dell dual xeons. This does not happen to all dell 
dual xeon 1600c system, just some.  I have not been able to duplicate 
in the lab, but some customers have corrected the problem by 
installing the 2.6.2 kernel with patched mtp fussion drives.

Version-Release number of selected component (if applicable):
2.4.21-9

How reproducible:
have not been able to do so

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Here is the out put from lspci -vv
 
  00:00.0 Host bridge: ServerWorks GCNB-LE Host Bridge (rev 32)
          Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr-
  Stepping- SERR- FastB2B-
          Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR-
 
  00:00.1 Host bridge: ServerWorks GCNB-LE Host Bridge
          Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr-
  Stepping- SERR- FastB2B-
          Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR-
 
  00:02.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet
Controller
  (rev 02)
          Subsystem: Dell Computer Corporation: Unknown device 0135
          Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr-
  Stepping- SERR+ FastB2B-
          Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR-
          Latency: 32 (63750ns min), cache line size 10
          Interrupt: pin A routed to IRQ 16
          Region 0: Memory at fe100000 (32-bit, non-prefetchable)
[size=128K]
          Region 2: I/O ports at ecc0 [size=64]
          Capabilities: [dc] Power Management version 2
                  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
  PME(D0+,D1-,D2-,D3hot+,D3cold+)
                  Status: D0 PME-Enable- DSel=0 DScale=1 PME-
          Capabilities: [e4] PCI-X non-bridge device.
                  Command: DPERE- ERO+ RBC=0 OST=0
                  Status: Bus=0 Dev=0 Func=0 64bit- 133MHz- SCD- USC-,
  DC=simple, DMMRBC=0, DMOST=0, DMCRS=0, RSCEM-      Capabilities: 
[f0]
  Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                  Address: 0000000000000000  Data: 0000
 
  00:0e.0 VGA compatible controller: ATI Technologies Inc Rage XL 
(rev 27)
  (prog-if 00 [VGA])
          Subsystem: Dell Computer Corporation: Unknown device 0135
          Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop+
ParErr-
  Stepping+ SERR- FastB2B-
          Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR-
          Latency: 32 (2000ns min), cache line size 10
          Region 0: Memory at fd000000 (32-bit, non-prefetchable) 
[size=16M]
          Region 1: I/O ports at e800 [size=256]
          Region 2: Memory at fe121000 (32-bit, non-prefetchable) 
[size=4K]
          Expansion ROM at <unassigned  [disabled] [size=128K]
          Capabilities: [5c] Power Management version 2
                  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
  PME(D0-,D1-,D2-,D3hot-,D3cold-)
                  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
  00:0f.0 Host bridge: ServerWorks CSB5 South Bridge (rev 93)
          Subsystem: ServerWorks CSB5 South Bridge
          Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr+
  Stepping- SERR+ FastB2B-
          Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort+  SERR- <PERR-
          Latency: 32
 
  00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller (rev 93) 
(prog-if
8a
  [Master SecP PriP])
          Subsystem: Dell Computer Corporation: Unknown device 4135
          Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr+
  Stepping- SERR+ FastB2B-
          Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR-
          Latency: 64, cache line size 08
          Region 0: I/O ports at <ignored 
          Region 1: I/O ports at <ignored 
          Region 2: I/O ports at <ignored 
          Region 3: I/O ports at <ignored 
          Region 4: I/O ports at 08b0 [size=16]
 
  00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller 
(rev 05)
  (prog-if 10 [OHCI])
          Subsystem: ServerWorks OSB4/CSB5 OHCI USB Controller
          Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr+
  Stepping- SERR+ FastB2B-
          Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR+
          Latency: 32 (20000ns max)
          Interrupt: pin A routed to IRQ 10
          Region 0: Memory at fe120000 (32-bit, non-prefetchable) 
[size=4K]
 
  00:0f.3 ISA bridge: ServerWorks GCLE Host Bridge
          Subsystem: ServerWorks: Unknown device 0230
          Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr+
  Stepping- SERR+ FastB2B-
          Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR-
          Latency: 0
 
  00:10.0 Host bridge: ServerWorks: Unknown device 0101 (rev 03)
          Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr+
  Stepping- SERR+ FastB2B-
          Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort+  SERR- <PERR-
          Capabilities: [60] PCI-X non-bridge device.
                  Command: DPERE- ERO- RBC=0 OST=4
                  Status: Bus=0 Dev=0 Func=0 64bit- 133MHz- SCD- USC-,
  DC=simple, DMMRBC=0, DMOST=0, DMCRS=0, RSCEM-
  00:10.2 Host bridge: ServerWorks: Unknown device 0101 (rev 03)
          Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr+
  Stepping- SERR+ FastB2B-
          Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort+  SERR- <PERR-
          Capabilities: [60] PCI-X non-bridge device.
                  Command: DPERE- ERO- RBC=0 OST=4
                  Status: Bus=0 Dev=0 Func=0 64bit- 133MHz- SCD- USC-,
  DC=simple, DMMRBC=0, DMOST=0, DMCRS=0, RSCEM-
  01:04.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 
PCI-X
  Fusion-MPT Dual Ultra320 SCSI (rev 07)
          Subsystem: Dell Computer Corporation: Unknown device 0135
          Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr-
  Stepping- SERR+ FastB2B-
          Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium  
TAbort-
  <TAbort- <MAbort-  SERR- <PERR-
          Latency: 72 (4250ns min, 4500ns max), cache line size 10
          Interrupt: pin A routed to IRQ 29
          Region 0: I/O ports at dc00 [size=256]
          Region 1: Memory at fcf10000 (64-bit, non-prefetchable) 
[size=64K]
          Region 3: Memory at fcf00000 (64-bit, non-prefetchable) 
[size=64K]
          Expansion ROM at fce00000 [disabled] [size=1M]
          Capabilities: [50] Power Management version 2
                  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
  PME(D0-,D1-,D2-,D3hot-,D3cold-)
                  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
          Capabilities: [58] Message Signalled Interrupts: 64bit+ 
Queue=0/0
  Enable-
                  Address: 0000000000000000  Data: 0000
Comment 1 Ernie Petrides 2004-03-05 18:58:15 EST
Hello, Curtis.  There's not enough information on this problem
for us to make progress on resolving it.  Could you please either
discover a way to reproduce the hang or provide some evidence of
what subsystem in the kernel might be causing it?

Thanks.  -ernie
Comment 2 Ernie Petrides 2004-06-14 20:39:47 EDT
Closing due to lack of response.  -ernie

Note You need to log in before you can comment on or make changes to this bug.