Bug 116221 - TCP packet problem with kernel 2.6.2-1.87
Summary: TCP packet problem with kernel 2.6.2-1.87
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-19 07:10 UTC by Andy Choi
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 19:09:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Choi 2004-02-19 07:10:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I am having network issues with the kernel version above and several
below it.
I have an Athlon 1800+ with a K7S5a (sis735) and I am using the built
in NIC sis900.
ICMP and UDP traffic to my LAN is fine, but TCP packets aren't.
Subsequently every connection looks like the host is down.

Is this a known problem or is it unique?  It's happen with several of
the newer kernel development versions.

Version-Release number of selected component (if applicable):
kernel-2.6.2-1.87

How reproducible:
Always

Steps to Reproduce:
1. have my system 
2. isntall FC1
3. install listed kernel version
4. TCP packets go heywire.
    

Actual Results:  TCP packets don't go out.

Expected Results:  A successful connection.

Additional info:

Nothing is shown when trying to initiate a TCP connection.

Comment 1 keith adamson 2004-02-21 21:31:50 UTC
check thread;
http://www.redhat.com/archives/fedora-test-list/2004-February/msg00652.html

either run command as root;

echo 0 > /proc/sys/net/ipv4/tcp_ecn

or add to file /etc/sysctl.conf and reboot;

# Disable ECN
net.ipv4.tcp_ecn = 0



Comment 2 Alan Cox 2004-05-03 19:09:42 UTC
Re-open if disabling ECN didnt fix this


Note You need to log in before you can comment on or make changes to this bug.