Bug 11630 - NDC reload generates spurious error message
NDC reload generates spurious error message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
: 12754 13081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-24 11:26 EDT by Henri J. Schlereth
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 09:00:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri J. Schlereth 2000-05-24 11:26:47 EDT
bind 8.2.2P5-9/-10
ndc reload generates following confusing message:
couldnt create pid file '/var/run/named.pid'

Note: The existing pid is used as the new PID id is inserted. Many
people on your redhat-install-list are getting confused by this.

NDC restart works just fine. I assume that it is a user change over
problem.
Comment 1 Bernhard Rosenkraenzer 2000-06-26 16:24:14 EDT
This should be fixed in the current version.
Comment 2 Henri Schlereth 2000-06-26 17:21:33 EDT
Tut mir leid bero, but it shows up still in bind-8.2.2p5-15 on beta2.
ndc reload:

Jun 26 16:00:39 rock named[508]: couldn't create pid file '/var/run/named.pid'
Jun 26 16:00:39 rock named[508]: Forwarding source address is [0.0.0.0].1026

henris@neandertal.org is my other account.
Comment 3 Henri Schlereth 2000-07-12 18:33:46 EDT
ndc reload still generates couldnt create 'pid file /var/run/named' in beta 3
Comment 4 Henri Schlereth 2000-07-12 18:36:49 EDT
*** Bug 12754 has been marked as a duplicate of this bug. ***
Comment 5 Henri Schlereth 2000-08-01 21:43:21 EDT
Tested on bind-8.2.2-P5-24 and it is fixed.
Comment 6 Henri Schlereth 2000-08-01 21:44:43 EDT
Sorry that was wrong ndc reload still exhibits error message / ndc restart works fine. Not a show stopper.
Comment 7 Henri Schlereth 2000-08-01 21:46:12 EDT
*** Bug 13081 has been marked as a duplicate of this bug. ***
Comment 8 Henri Schlereth 2000-08-22 20:36:06 EDT
Can be fixed by recompiling bind to point named.pid to /var/named (chroot jail) or set the caching-nameserver software to
have 

pidfile="/var/named/named.pid"

added to the options statement in named.conf.

Not the exact syntax (dont have it before me but it works)
Comment 9 Bernhard Rosenkraenzer 2000-12-20 17:31:17 EST
The current version fixes this by moving the pid file to /var/run/named. Not
exactly the standard location, but better than making /var/run world-writable...
Comment 10 Henri Schlereth 2001-03-20 09:00:14 EST
This error has re-appeared in Bind 8.2.3.
Comment 11 Bernhard Rosenkraenzer 2001-05-17 06:10:49 EDT
It's gone for good in 9.x

Note You need to log in before you can comment on or make changes to this bug.