Bug 116302 - Installer hangs after asking for the root password
Installer hangs after asking for the root password
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 16:15 EST by Preston Wade
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:45:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump from installer (40.90 KB, text/plain)
2004-02-19 16:25 EST, Preston Wade
no flags Details

  None (edit)
Description Preston Wade 2004-02-19 16:15:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030417

Description of problem:
The scenario is.  Installing ES 2.1 Update 3 over the network via
http.  Starting the install from a bootnet floppy with a kickstart
config file on it.  The kickstart config file is setup in such a way
that it only prompts me for a root password.  After I enter the root
password anaconda spits out some errors.

Version-Release number of selected component (if applicable):
anacron-2.3-17.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Use a bootnet floppy with a kickstart config file.
2. type linux ks=floppy dd
3. enter root password
    

Additional info:
Comment 1 Preston Wade 2004-02-19 16:25:21 EST
Created attachment 97845 [details]
dump from installer
Comment 2 Jeremy Katz 2004-02-19 16:39:24 EST
This looks like you're doing an HTTP install and getting an error
reading the hdlist file -- can you verify the permissions are such
that you can download RedHat/base/hdlist and RedHat/base/hdlist2?
Comment 3 Preston Wade 2004-02-19 17:15:33 EST
thirdtwn:/home/kickstart/kickstart/RedHat/ES2.1/disc1/RedHat/base>ls -
l
total 78576
-r--r--r--    1 root     root          354 Dec 17 17:05 TRANS.TBL
-rw-r--r--    1 root     root        20862 Dec 15 20:49 comps
-rw-r--r--    1 root     root      1689332 Dec 15 21:03 hdlist
-rw-r--r--    1 root     root     13634456 Dec 15 21:03 hdlist2
-rw-r--r--    1 root     root      6594560 Dec 15 21:01 hdstg1.img
-rw-r--r--    1 root     root      7102464 Dec 15 21:01 netstg1.img
-rw-r--r--    1 root     root     49827840 Dec 15 21:02 stage2.img
-rw-r--r--    1 root     root      1474560 Dec 17 15:52 updates.img
thirdtwn:/home/kickstart/kickstart/RedHat/ES2.1/disc1/RedHat/base>
Comment 4 Preston Wade 2004-02-19 17:20:43 EST
The permissions are the same for an ES3.0 setup and it works great.  
I would load 3.0 but the application I need to run is only certified 
on 2.1.
Comment 5 Jeremy Katz 2004-02-19 17:45:26 EST
What happens if you try to grab the hdlist and hdlist2 files via http?
Comment 6 Preston Wade 2004-02-19 18:36:23 EST
The permissions are the same for an ES3.0 setup and it works great.  
I would load 3.0 but the application I need to run is only certified 
on 2.1.
Comment 7 Preston Wade 2004-02-19 18:38:53 EST
I used wget and retreived the file from a remote server.
[pwade@pwadeamd pwade]$ wget 
http://thirdtwn/kickstart/RedHat/ES2.1/disc1/RedHat/base/hdlist
--17:43:03--  
http://thirdtwn/kickstart/RedHat/ES2.1/disc1/RedHat/base/hdlist
           => `hdlist'
Resolving thirdtwn... done.
Connecting to thirdtwn[10.1.1.160]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1,689,332 [text/plain]

100%[====================================>] 1,689,332      8.95M/s    
ETA 00:00

17:43:03 (8.95 MB/s) - `hdlist' saved [1689332/1689332]

[pwade@pwadeamd pwade]$ wget 
http://thirdtwn/kickstart/RedHat/ES2.1/disc1/RedHat/base/hdlist2
--17:43:10--  
http://thirdtwn/kickstart/RedHat/ES2.1/disc1/RedHat/base/hdlist2
           => `hdlist2'
Resolving thirdtwn... done.
Connecting to thirdtwn[10.1.1.160]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13,634,456 [text/plain]

100%[====================================>] 13,634,456    10.98M/s    
ETA 00:00

17:43:11 (10.98 MB/s) - `hdlist2' saved [13634456/13634456]

[pwade@pwadeamd pwade]$
Comment 8 Preston Wade 2004-06-17 13:48:54 EDT
I am trying to load another box and am having the same issue.  I 
can't remember how I worked around it last time.  Were you able to 
recreate the problem?
Comment 9 Jeremy Katz 2005-09-21 16:45:38 EDT
This should be resolved in current products.

Note You need to log in before you can comment on or make changes to this bug.