Bug 116325 - anytopnm calls -t option of mktemp which is not supported in current version of mktemp
anytopnm calls -t option of mktemp which is not supported in current version ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: netpbm (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 21:01 EST by Anthony Rumble
Modified: 2013-07-02 18:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 08:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Rumble 2004-02-19 21:01:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1)
Gecko/20020508 Netscape6/6.2.3

Description of problem:
In latest errata of netpbm, anytopnm calls

mktemp -d -t anytopnm.XXXXXXXXXX

-t is not supported in the version of mktemp that is current in RH 9.



Version-Release number of selected component (if applicable):
netpbm-progs-9.24-10.90.1

How reproducible:
Always

Steps to Reproduce:
1.run anytopnm to convert a graphic
2.you will get an error from mktemp
3.
    

Additional info:
Comment 1 Phil Knirsch 2004-02-20 04:20:07 EST
We are aware of this bug and are currently working on an updated
errata for mktemp and netpbm for RH 9.

In the meantime using the FC1 version of mktemp should work, but that
hasn't been tested.

Thanks,

Read ya, Phil
Comment 2 Jindrich Novy 2004-09-14 08:40:32 EDT
Hi Anthony,

mktemp should accept -t since mktemp-1.3 (from mktemp's release notes)
However the mktemp-1.5-18 present in RH9 doesn't support it. It works
fine with the current release of mktemp.

Jindrich

Note You need to log in before you can comment on or make changes to this bug.