Bug 116346 - old K&R code needs upgrading
old K&R code needs upgrading
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 07:05 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 14:31:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-20 07:05:06 EST
Description of problem:

I just tried to compile development package cyrus-imapd-2.2.3-2

It appears to be a whole lot of very old K&R code. The compiler
got really upset about it, saying all this

include.c(220): remark #1011: missing return statement at end of
non-void function "remove_dotdot"
include.c(290): remark #117: non-void function "included_by" should
return a value
include.c(321): remark #117: non-void function "included_by" should
return a value
include.c(327): remark #1011: missing return statement at end of
non-void function "included_by"
include.c(336): remark #1011: missing return statement at end of
non-void function "inc_clean"
main.c(201): remark #1009: return type "int" omitted in declaration of
function "main"
main.c(525): remark #1011: missing return statement at end of non-void
function "freefile"
main.c(663): remark #117: non-void function "redirect" should return a
value
main.c(715): remark #1011: missing return statement at end of non-void
function "redirect"
main.c(758): remark #1011: missing return statement at end of non-void
function "warning"
main.c(776): remark #1011: missing return statement at end of non-void
function "warning1"
parse.c(476): remark #1011: missing return statement at end of
non-void function "define"
parse.c(542): remark #117: non-void function "define2" should return a
value
parse.c(554): remark #1011: missing return statement at end of
non-void function "define2"
parse.c(608): remark #1011: missing return statement at end of
non-void function "undefine"
pr.c(95): remark #117: non-void function "add_include" should return a
value
pr.c(116): remark #1011: missing return statement at end of non-void
function "add_include"
pr.c(125): remark #117: non-void function "recursive_pr_include"
should return a value
pr.c(131): remark #1011: missing return statement at end of non-void
function "recursive_pr_include"
pr.c(161): remark #117: non-void function "pr" should return a value
pr.c(167): remark #1011: missing return statement at end of non-void
function "pr"

I count 21 places where the code needs upgrading. 
Got to leave the 1980s behind sometime.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Dennis 2005-02-10 14:31:40 EST
Since Red Hat does not maintain the source code for cyrus-imapd, we
only repackage it and apply select patches, we are not the ones to
clean up the projects coding style. If you would like to bring your
concerns to the attention of the cyrus-imapd developers responsible
for code maintenance you may find them here:

http://asg.web.cmu.edu/cyrus

about half way down the page is a link to their bug reporting system.

Note You need to log in before you can comment on or make changes to this bug.