Bug 116353 - missing return statement
missing return statement
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 09:32 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 07:30:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-20 09:32:36 EST
Description of problem:

I just tried to compile development package emacs-21.3-9

The compiler said

keyboard.c(1320): warning #1011: missing return statement at end of
non-void function "cancel_hourglass_unwind"

The source code is

static Lisp_Object
cancel_hourglass_unwind (arg)
     Lisp_Object arg;
{
  cancel_hourglass ();
}

Looks like a missing return statement to me. You might also
like to convert this code from K&R to ISO.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jens Petersen 2004-04-15 11:36:55 EDT
I'm happy to accept unintrusive patches to fix these kind of
compiler warnings, but I recommend taking this upstream: eg
reporting it on emacs-devel.

Note You need to log in before you can comment on or make changes to this bug.