Bug 116397 - 3c59x driver: network doesn't work on Dell Latiitude CPx laptop
3c59x driver: network doesn't work on Dell Latiitude CPx laptop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 13:55 EST by Dimitri Papadopoulos
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-09 13:08:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (9.95 KB, text/plain)
2004-02-20 14:23 EST, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Dimitri Papadopoulos 2004-02-20 13:55:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040113

Description of problem:
I can't get the network to work on my Dell Latitude CPx laptop.

Some information on this machine. It's a Dell Latitude CPx, model PPX:
http://docs.us.dell.com/docs/Systems/pcpxhj/en/ug_a02/specs.htm

# lspci -v
[...]
0000:06:00.0 Ethernet controller: 3Com Corporation 3CCFE575CT Cyclone
CardBus (rev 10)
	Subsystem: 3Com Corporation FE575C-3Com 10/100 LAN CardBus-Fast Ethernet
	Flags: bus master, medium devsel, latency 64, IRQ 11
	I/O ports at 4800 [size=268M]
	Memory at 11000000 (32-bit, non-prefetchable) [size=128]
	Memory at 11000080 (32-bit, non-prefetchable) [size=128]
	Expansion ROM at 00020000 [disabled]
	Capabilities: [50] Power Management version 2
[...]
# 

Usually the card just doesn't work:

# mii-tool -v
  No MII transceiver present!.
# 

Once in a while I boot the laptop and the card does work:

# mii-tool -v
eth0: autonegotiation failed, link ok
  product info: TDK 78Q2120 rev 11
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
# 
# mii-tool -F 10baseT-HD
# 
# mii-tool -v
eth0: 10 Mbit, half duplex, link ok
  product info: TDK 78Q2120 rev 11
  basic mode:   10 Mbit, half duplex
  basic status: link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
# 

Note that autonegotiation is disabled on our network (don't ask me
why). This is why I have to force a 10baseT-HD connection. But anyway,
in this case the network card does work.

Please tell me if you need additional information such as boot messages.


Version-Release number of selected component (if applicable):
kernel-2.6.1-1.65

How reproducible:
Sometimes
Comment 1 Dimitri Papadopoulos 2004-02-20 14:06:21 EST
Mmmh... Actually this could be a duplicate of bug 102685.

Disabling kudzu at startup makes the card work better as suggested: at
least mii-tools doesn't report "No MII transceiver present!.".

However many packets are still dropped:

# ping 172.16.4.36
PING 172.16.4.36 (172.16.4.36) 56(84) bytes of data.
From 172.16.4.23 icmp_seq=0 Destination Host Unreachable
[...]
64 bytes from 172.16.4.36: icmp_seq=54 ttl=255 time=9245 ms
[...]
ping: sendmsg: No buffer space available
[...]
--- 172.16.4.36 ping statistics ---
100 packets transmitted, 66 received, +12 errors, 34% packet loos,
time 142982ms rtt [...]
# 
# ping 172.16.4.36
PING 172.16.4.36 (172.16.4.36) 56(84) bytes of data.
From 172.16.4.23 icmp_seq=0 Destination Host Unreachable
[...]
--- 172.16.4.36 ping statistics ---
25 packets transmitted, 0 received, +21 errors, 100% packet loos, time
23989ms rtt, pipe 5
# 
Comment 2 Dimitri Papadopoulos 2004-02-20 14:23:37 EST
Created attachment 97877 [details]
dmesg
Comment 3 Dave Jones 2004-02-20 19:15:48 EST
please try the latest kernel, there have been a *lot* of network
driver fixes in the last few days
Comment 4 Dimitri Papadopoulos 2004-02-23 10:58:23 EST
I've installed kernel-2.6.3-1.97 and it fixes both problems:
* the interface is not messed up when running kudzu
* no more packet loss
Thanks!
Comment 5 Dimitri Papadopoulos 2004-03-04 10:28:00 EST
I have upgraded to kernel-2.6.3-1.106 and kernel-2.6.3-1.118 and now I
experience network problems again.

Is it OK to reopen this bug report? Do you need additional information?

This time the device isn't even visible to the system:
	# lspci | fgrep 3Com
	#
	# kudzu --probe | fgrep 3Com
	#

Of course mii-tool reports no device:
	# mii-tool -v
	no MII interfaces found
	# 

Module 3c59x is not loaded:
	# lsmod
	Module                  Size  Used by
	ext3                  115240  2
	jbd                    72472  1 ext3
	# 
Comment 6 Dimitri Papadopoulos 2004-03-10 15:55:48 EST
I have reinstalled Fedora Core Test 2 from scratch and directly
updated to kernel-2.6.3-1.164.

Now the network runs just fine.

Either this was a problem with kernel-2.6.3-1.106 and
kernel-2.6.3-1.118, or the successive updates had messed up the system.

I noticed some errors in the post-install scripts or translated
descriptions of some packages, which may account for the problem...
Comment 7 Dimitri Papadopoulos 2004-03-12 07:59:43 EST
I'm terribly sorry to have opened and closed this issue so many times,
but the problem appears to be transient, so the network sometimes
works and usually doesn't.

So I still have problems, both with kernel 2.6.3-1.146 and 2.6.3-1.153.

At least the newtork card seems to be detected correctly:

# lspci | fgrep 3Com
0000:06:00.0 Ethernet controller: 3Com Corporation 3CCFE575CT Cyclone
CardBus (rev 10)
# mii-tool
eth0: 10 Mbit, half duplex, link ok
# 

The network configuration looks OK to me:

# ifconfig eth0
eth0	Lien encap:Ethernet  HWaddr 00:01:03:A8:6C:AD
	inet adr:172.16.4.23  BCast:172.16.7.255  Masque:255.255.252.0
	adr inet6: fe80::201:3ff:fea8:6cad/64 Scope:Lien
	UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	RX packets:653 errors:0 dropped:0 overruns:1040 frame:0
	TX packets:142 errors:7 dropped:0 overruns:0 carrier:2
	collisions:11 lg file transmission:1000
	RX bytes:56271 (54.9 Kb)  TX bytes:11243 (10.9 Kb)
	Interruption:11 Adresse de base:0x4800
# 

but there are lots of packets dropped (when pinging a machine on the
same network) between 100% (most often) and 0% (sometimes).
Comment 8 Dimitri Papadopoulos 2004-03-12 08:01:15 EST
Ouch! My current kernel is 2.6.3-2.1.253, not 2.6.3-1.153. Sorry.
Comment 9 Dimitri Papadopoulos 2004-04-09 13:08:13 EDT
I've upgraded to FC2 test2 and the network has been running for days.
DNS lookups, updates, and large file transfers work just fine.

I guess something used to go wrong with FC2 test1 updates, or
something like that. Case closed.


Note You need to log in before you can comment on or make changes to this bug.