Bug 116405 - spadmin printer configuration utility fails
spadmin printer configuration utility fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 14:25 EST by Vladimir Vuksan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 14:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Vuksan 2004-02-20 14:25:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I would like to add a new printer in OpenOffice however	spadmin 
 	
> /usr/lib/ooo-1.1.0/program/spadmin
/usr/lib/ooo-1.1.0/program/spadmin: line 239:
/usr/lib/ooo-1.1.0/program/spadmin.bin: No such file or directory
/usr/lib/ooo-1.1.0/program/spadmin: line 239: exec:
/usr/lib/ooo-1.1.0/program/spadmin.bin: cannot execute: No such file
or directory

Looking in /usr/lib/ooo-1.1.0 spadmin is just a link to soffice. 

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-24

How reproducible:
Always

Steps to Reproduce:
Execute 

/usr/lib/ooo-1.1.0/program/spadmin

Additional info:
Comment 1 Dan Williams 2004-02-20 14:41:58 EST
Please upgrade to ooo-1.1.0-27 or later.  spadmin is no longer
included with OOo, since all printers are discovered through CUPS. 
Use the Print Manager to add/remove your printers.
Comment 2 Bob T. 2004-04-12 08:05:30 EDT
Without spadmin, there is no way to configure font embedding and font
substitution for conversion to PDF.  
Comment 3 Dan Williams 2004-04-12 10:14:03 EDT
spadmin is not supported with OOo 1.1.0-20 and later.  If you need
print to PDF, please use File->Print to PDF...  Fonts should be
embedded according to their licensing details (for TrueType fonts at
least).

If you _need_ to use Ghostscript or another PDF program, use
File->Print, check the "Print to File" checkbox to save the document
as straight PostScript.  You will need to add a dummy printer to
Fedora Core using the printconf-gui (System Settings->Printing), but
that is the same thing that spadmin does anyway.
Comment 4 Bob T. 2004-04-12 18:00:49 EDT
Font embedding/substitution should be configurable because the user
has to choose between fidelity (all fonts embedded) and PDF size
minimization (fonts not embedded).  This will be determined by how one
intends to use the PDF: pre-press, e-mailed to particular recipients
with known fonts, on the web, etc.  Just providing an "Export to PDF"
button simply isn't good enough. I can understand why Red Hat wants to
get rid of spadmin but try to get the OpenOffice people to move the
configurability it provides to the Options menu. And, yes, this can
all be done using Export to Postscript and ps2pdf, but have you ever
tried to configure ps2pdf?  Check out

http://bugs.ghostscript.com/show_bug.cgi?id=687373

for a look at how badly this application is documented. In effect, one
has to configure the conversion in Postscript!
Comment 5 Dan Williams 2004-04-12 18:10:54 EDT
Any printing to a PDF printer using spadmin required you to set up
ps2pdf or the Acrobat Distiller anyway... I don't follow how spadmin
allows you to get away from that.

In any case, this sounds more like a feature request for upstream...

Also, the PPD file you choose for your printer in the Fedora Core
print center controls the font embedding, _not_ OOo.  If the PPD has
"*TTRasterizer: Type42" in it, your TrueType fonts are embedded.

Also, if you weren't aware, right after the save dialog for
File->Export as PDF, a dialog pops up that allows you to choose from:

o Screen optimized (smallest file)
o Print optimized
o Press optimized

Which I assume control DPI and font embedding options.
Comment 6 Bob T. 2004-04-12 18:33:08 EDT
>Any printing to a PDF printer using spadmin required you to set up
ps2pdf or the Acrobat Distiller anyway... I don't follow how spadmin
allows you to get away from that.

There's no set-up needed for using ps2pdf. Spadmin allowed you to
control font substitutions; redhat-config-printer doesn't.

>In any case, this sounds more like a feature request for upstream...

You're taking away an existing feature (albeit one not well designed).

>Also, the PPD file you choose for your printer in the Fedora Core
print center controls the font embedding, _not_ OOo.  If the PPD has
"*TTRasterizer: Type42" in it, your TrueType fonts are embedded.

One needs finer control.  For example, often Times replacing Times New
Roman is "good enough"; in other circumstances it isn't.

>Also, if you weren't aware, right after the save dialog for
File->Export as PDF, a dialog pops up that allows you to choose from:

o Screen optimized (smallest file)
o Print optimized
o Press optimized

Which I assume control DPI and font embedding options.

As far as I can tell, only the DPI of graphic images is affected by
this choice; but it's another place where real configurability could go.
Comment 7 Dr. Tilmann Bubeck 2004-05-21 17:28:24 EDT
Please include spadmin. You need it for:
  * setup fax printing inside OOo
  * Include Fonts into OOo correctly
  * setup pdf creating WITHOUT fuzzy fonts

Otherwise important functionality is missing from OOo!

Note You need to log in before you can comment on or make changes to this bug.