Bug 116436 - texinfo has zlib devel build dependency
texinfo has zlib devel build dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 19:56 EST by Thomas Gordon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-21 12:41:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Gordon 2004-02-20 19:56:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
devel texinfo src package does not compile due to missing zlib.h (see
actual results).  this is part of zlib-devel which is not specified in
the texinfo source package.

Version-Release number of selected component (if applicable):
texinfo-4.6-2.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.rpmbuild --rebuild texinfo-4.6-2.src.rpm

    

Actual Results:  install-info.c:23:18: zlib.h: No such file or directory
install-info.c:470: error: syntax error before
"open_possibly_compressed_file"
install-info.c: In function `open_possibly_compressed_file':
install-info.c:481: error: `gzFile' undeclared (first use in this
function)
install-info.c:481: error: (Each undeclared identifier is reported
only once
install-info.c:481: error: for each function it appears in.)
install-info.c:481: error: `f' undeclared (first use in this function)
install-info.c: In function `readfile':
install-info.c:556: error: `gzFile' undeclared (first use in this
function)
install-info.c:556: error: `f' undeclared (first use in this function)
make[2]: *** [install-info.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/texinfo-4.6/util'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/texinfo-4.6'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.65860 (%build)

Expected Results:  + exit 0

Additional info:

just add zlib-devel to buildrequires

Note You need to log in before you can comment on or make changes to this bug.