Bug 116446 - mkbootdisk floppy results in kernel panic
mkbootdisk floppy results in kernel panic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mkbootdisk (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
: 109834 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 22:45 EST by M Jang
Modified: 2008-02-18 20:38 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 20:38:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M Jang 2004-02-20 22:45:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.23  [en]

Description of problem:
Similar to 109834 - the mkbootdisk command creates a floppy which 
results in a kernel panic when booting from that floppy. 

That floppy works if the syslinux.cfg file is repaired; my original 
syslinux.cfg file is:

display boot.msg
timeout 100
label linux
     kernel vmlinuz
     append initrd=initrd.img ro
ro root=/dev/hda2

However, it works normally if the last two lines are combined into:

     append initrd=initrd.img ro root=/dev/hda2

Version-Release number of selected component (if applicable):
1.5.1-1

How reproducible:
Always

Steps to Reproduce:
1. run mkbootdisk `uname -r`
2. reboot with floppy in the drive
3.
    

Actual Results:  Kernel panic

Expected Results:  Booting into the current Enterprise Linux 
installation

Additional info:
Comment 1 Peter Vrabec 2004-10-12 10:29:00 EDT
*** Bug 109834 has been marked as a duplicate of this bug. ***
Comment 2 David Lawrence 2006-07-17 22:51:07 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.