Bug 116451 - rpm -e segmentation fault
rpm -e segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-21 03:19 EST by Darren Gitelman
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 15:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Gitelman 2004-02-21 03:19:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
Seg. fault occurs with
rpm -e package_name
rpm -i (U)vh package_name
where package_name is any package that I try.

No seg. fault
rpm --help
rpm -qa -vv
rpm -V -vv rpm popt
--------------------

[root@mistral rpm]# rpm -e -vv mozilla-mail-1.0.2-2.8.0
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Pubkeys rdonly mode=0x0
D:  read h#     738 Header sanity check: OK
D: ========== DSA pubkey id 219180cddb42a60e
D:  read h#     818 Header V3 DSA signature: OK, key ID db42a60e
D: ========== --- mozilla-mail-1.0.2-2.8.0
D: opening  db index       /var/lib/rpm/Requirename rdonly mode=0x0
D:  read h#     293 Header V3 DSA signature: OK, key ID db42a60e
D: opening  db index       /var/lib/rpm/Depends create mode=0x0
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D:  read h#      91 Header V3 DSA signature: OK, key ID db42a60e
D:  Requires: libmsgbaseutil.so                             YES (db
provides)
D: closed   db index       /var/lib/rpm/Depends
D: closed   db index       /var/lib/rpm/Pubkeys
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Requirename
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages create mode=0x42
D: getting list of mounted filesystems
D: sanity checking 1 elments
D: computing 37 file fingerprints
D: computing file dispositions
D: opening  db index       /var/lib/rpm/Basenames create mode=0x42
D: ========== --- mozilla-mail-1.0.2-2.8.0
D:     erase: mozilla-mail-1.0.2-2.8.0 has 37 files, test = 0
D: opening  db index       /var/lib/rpm/Name create mode=0x42
D:  read h#     818 Header V3 DSA signature: OK, key ID db42a60e
Segmentation fault


I have already tried
rm -f /var/lib/rpm/__db.*
rpm --rebuilddb

Still get same segmentation fault.
strace output can be found at ftp://165.124.234.145/pub/drg/strace.txt.gz

Version-Release number of selected component (if applicable):
rpm-4.1-1.06

How reproducible:
Always

Steps to Reproduce:
1.type commands as above
2.
3.
    

Actual Results:  segmentation fault

Expected Results:  package would be uninstalled or installed properly

Additional info:

I haven't made any recent changes to the system other than installing
mozilla 1.6, but this was done through their non-rpm install process.
I read some other bugzilla postings and nscd -d also seems broken with
the folllowing error:

nscd: relocation error: nscd: symbol __nss_disable_nscd, version
GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

but I'm just not sure what to do.
Comment 1 Darren Gitelman 2004-02-21 15:51:32 EST
Following up: I tried suggestions in other bugs reporting rpm -i
(U)(e) errors to reinstall nscd or rpm using rpm2cpio, but that didn't
help. I then tried downgrading my glibc installation from 2.3.2-11.9
to 2.2.93-5. This turns out to have been an exceedingly bad idea and
everything stopped working. After fussing with tomsrtbt the system is
now back up again with the glibc-2.3.2-11.9 but the rpm problem remains.
Comment 2 Jeff Johnson 2004-02-21 17:13:56 EST
Try
    rm -f /var/lib/rpm/Pubkeys
(a crude way of specifiying --nosignature).

If that fixes, then rpm-4.2.2 or later is recommended.

Meanwhile, --rebuilddb will regenerate Pubkeys whenever.
Comment 3 Darren Gitelman 2004-02-21 17:49:23 EST
I tried rm -f /var/lib/rpm/Pubkeys, then rpm --rebuilddb. I also tried
removing __db.* and --rebuilddb. Still get a segmentation fault.
Comment 4 Darren Gitelman 2004-02-26 18:58:28 EST
Just waiting to hear back with any further suggestions. This problem
has not been solved.

Note You need to log in before you can comment on or make changes to this bug.