Bug 116453 - local variable used before set
local variable used before set
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-21 05:19 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 12:25:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-21 05:19:38 EST
Description of problem:

I just tried to compile development package file-roller-2.5.2-1

The compiler said

dlg-add.c(643): remark #592: variable "same_fs" is used before its
value is set

The source code is

        config_set_bool   (opt_file_path, "same_fs", same_fs);

Suggest init same_fs before first use.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marco Pesenti Gritti 2004-10-27 12:25:42 EDT
The problem is no more in recent versions of file-roller.

Note You need to log in before you can comment on or make changes to this bug.