Bug 116507 (IT_44731) - rpm -q -redhatprovides fails after Q3 update
Summary: rpm -q -redhatprovides fails after Q3 update
Status: CLOSED ERRATA
Alias: IT_44731
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rpmdb-redhat   
(Show other bugs)
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Flanagan
QA Contact:
URL:
Whiteboard:
Keywords:
: 117944 (view as bug list)
Depends On:
Blocks: 132992
TreeView+ depends on / blocked
 
Reported: 2004-02-22 01:11 UTC by Richard Newbigin
Modified: 2007-11-30 22:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-06 15:16:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:398 high SHIPPED_LIVE rpmdb-redhat bug fix update 2005-05-06 04:00:00 UTC

Description Richard Newbigin 2004-02-22 01:11:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20031013

Description of problem:
The update seems to use a new rpmdb format which is not compatible
with either rpm or db3


Version-Release number of selected component (if applicable):
rpmdb-redhat-2.1ES-0.20031215

How reproducible:
Always

Steps to Reproduce:
1. Install ES2.1 & rpmdb-redhat
2. Update to latest rpmdb-redhat
3. run rpm -q -redhatprovides rpm
    

Actual Results:  rpmdb:
/usr/lib/rpmdb/i386-redhat-linux/redhat/Packages: unsupported hash
version: 8
error: cannot open Packages index using db3 - Invalid argument (22)


Expected Results:  rpm-4.0.4-7x.20

Additional info:

AFAIK, the rpmdb should be in Berkeley DB (Hash, version 7, native
byte-order) but is instead in  Berkeley DB (Hash, version 8, native
byte-order).  Perhaps this would be solved with an update to rpm or
db3 rather than a rebuild of rpmdb in V7 format.

Comment 2 Jeff Johnson 2004-02-27 03:17:24 UTC
The fix is in the rpmdb-redhat package which is mis-built
with an rpm version that uses db-4.1.25, not db-4.0.14.


Comment 3 Richard Newbigin 2004-03-17 09:40:34 UTC
Any chance of getting this fixed?

Comment 4 Richard Newbigin 2004-06-05 10:51:46 UTC
Guess what, this is still broken in U4...

Comment 5 Bastien Nocera 2004-08-03 14:08:43 UTC
*** Bug 117944 has been marked as a duplicate of this bug. ***

Comment 12 John Flanagan 2005-05-06 15:16:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-398.html



Note You need to log in before you can comment on or make changes to this bug.