Bug 116509 - Sony DVD RW-U14A produces no audio
Sony DVD RW-U14A produces no audio
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-21 20:51 EST by john.himpel
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 14:44:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john.himpel 2004-02-21 20:51:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Epiphany/1.0.7

Description of problem:
I have configured alsa sound and can hear audio from other sources
(test, mp3, realplayer, etc).
I cannot hear audio from a audio cd.
CDP gives "Wait... Reading CD Status..."
I have /dev/cdrom linked to /dev/hda
I can mount data disks on that drive and read/write them.
It worked with alsa under 2.4 kernels.
It works with M$.


Version-Release number of selected component (if applicable):
kernel-2.1.6-65smp

How reproducible:
Always

Steps to Reproduce:
1.Insert audio cd
2.run cdp
3.
    

Actual Results:  CDO hangs on the message Wait... Reading CD Status ...

Expected Results:  I expect to hear audio

Additional info:

Gnome's CD Player says "Invalid CD Device"

/etc/grub.conf
title Fedora Core (2.6.1-1.65smp)
        root (hd0,1)
        kernel /vmlinuz-2.6.1-1.65smp ro root=LABEL=/ hda=ide-scsi rhgb
        initrd /initrd-2.6.1-1.65smp.img
Comment 1 Mike A. Harris 2004-02-23 00:31:46 EST
This isn't a bug in cdp.
Comment 2 Arjan van de Ven 2004-02-23 03:10:42 EST
hda=ide-scsi 
is wrong. Very wrong.
Please try without that.
Comment 3 John Himpel 2004-02-23 07:29:25 EST
cdp and Sound and Video->CD Player now find the device properly. Only
getting a "popping" noise from speaker (yes, I have changed mixer
settings with alsamixer). But I can work on that myself.

ide-scsi is being added to grub.conf by either grub or kernel.rpm as I
am not setting it.  So should I file a bug against one of them?

Thanks!

File a bug at 8:00PM on Sunday and get a fix by 4:00AM Monday. Who
says there is no support? :-)

Comment 4 Bill Nottingham 2004-02-23 18:25:46 EST
Did you do an upgrade with yum/up2date, or a fresh install?
Comment 5 John Himpel 2004-02-23 19:06:04 EST
The original install was FC1 from CDROM using the 2.4 kernels.
Subsequently, all updates have been done via YUM.  Shortly before
test1 was made available, I switched to 2.6 kernels (yum install
kernel-2.6,,,,).  Since then I have used yum to install all subsequent
kernels.

Each kernel that gets installed via yum, gets ids-scsi=/dev/hda in the
boot stanza in grub.conf.

Hope this answers your question.
Comment 6 john.himpel 2004-03-03 14:44:08 EST
Removing the ids-scsi=/dev/hda solved the problem.

Note You need to log in before you can comment on or make changes to this bug.