Bug 116528 - eggcups segfaults
eggcups segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-22 14:44 EST by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-22 17:56:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2004-02-22 14:44:12 EST
Description of problem:
Since a recent update, eggcups segfaults immediately, so every time a 
user logs in (using gdm).

Version-Release number of selected component (if applicable):
desktop-printing-0.1.10-22

How reproducible:
always

Steps to Reproduce:
1. eggcups
2.
3.
  
Actual results:
(eggcups:11859): Gtk-WARNING **: GModule initialization check failed: 
Gtk+ version too old (micro mismatch)

(gnome_segv:11860): Gtk-WARNING **: GModule initialization check 
failed: Gtk+ version too old (micro mismatch)

[Segfault]

Expected results:
Don't know. No message at all probably.

Additional info:
I assume the "Gtk+ version too old" messages have a different cause, 
and aren't related to this crash.

strace tells me that eggcups was most recently reading 
/var/run/dbus/system_bus_socket .

Here are some of the versions I've got installed:
desktop-printing-0.1.10-22
gtk+-1.2.10-28.1
gtk2-2.2.4-5.2
ORBit-0.5.17-10.3
atk-1.4.0-1
cups-libs-1.1.20-1
pango-1.2.5-1.1
GConf-1.0.9-11
Comment 1 Tim Waugh 2004-02-22 17:56:50 EST
Upgrade to desktop-printing-0.1.10-24, as well as the most recent
versions of dbus-* and cups-*.

Note You need to log in before you can comment on or make changes to this bug.