Bug 116597 - Lots of weirdness after kernel upgrade
Lots of weirdness after kernel upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 12:21 EST by David Jansen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-23 12:58:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2004-02-23 12:21:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
FC2 test1 was working reasonably well on my test box, until I used
up2date to update all packages. Test box is a very old system:
P II 350 MHz, 256 MB memory,

A couple of things I noticed, and all of them can be traced to wrong
interaction between the kernel and various other packages 9at least
gpm, kudzu and probably sshd)
                                                                     
          
1) the new kernel (2.6.3-1.97) does not become the default in grub
                                                                     
          
2) every time I switch between the 2.6.1-1.65 and 2.6.3-1.97 kernels,
kudzu thinks the keyboard is a new piece of hardware. Both kernels
identify it as "AT Translated Set 2 keyboard", and mention that a
device with the exact same name has been removed.
No big deal, just weird.
                                                                     
          
3) after this upgrade, the graphical boot is gone, and so is X
when starting X the screen will go blank a couple of times and then a
text mode dialog will pop up stating that the mouse is not set up
correctly. it offers to run the mouse configuration utility, and this
utility offers the correct mouse type (generic wheel mouse PS/2)
but reconfiguration doesn't help, still no X. Which is correct in a
way, since the gpm service is not running.
However, the gpm init script gives a green OK when starting.
Output in /var/log/messages:
O0o.oops(): [gpm.c(937)]: Could not open /dev/psaux
OK, I found part of this, psaux is no longer there. So maybe this is a
separate bug in system-config-mouse

4) When sshd is starting, an error appears:
/sbin/ifup: configuration for sit0 not found.
Usage: ifup <device name>
Well, I can believe the configuration is not found, I only have the lo
and eth0 interfaces configured. However, sshd is running despite this
error. If I'm not mistaken, sit0 is a UPv6 tunnel interface. Is IPv6
mandatory in kernel 2.6.3 ?


Version-Release number of selected component (if applicable):
kernel-2.6.3-1.97 kudzu-1.1.44-1.1 gpm-1.20.1-41

How reproducible:
Always

Steps to Reproduce:
1. update all packages including kernel
2. reboot in kernel 2.6.3-1.97
3.
    

Additional info:
Comment 1 Dave Jones 2004-02-23 12:41:06 EST
please don't file multiple bugs in a single report, it makes them very
awkward to resolve.

1) grub issue.
2) NOTABUG - will be 'the norm' from now on.
3) dupe - see 116092
4) not unless you've been playing with any ipv6 related options in
your configs / redhat-config-network
Comment 2 David Jansen 2004-02-23 12:53:03 EST
OK, I'll file separate bugs about issue 1 and 4 (haven't done anything
with IPv6, the new kernel seems to have automatically added that
interface).

At 2: you mean 'the norm' will be to indicate the hardware has changed
when the kernel gets updated? sounds confusing to me.
Comment 3 Dave Jones 2004-02-23 12:58:44 EST
ISTR there were recent changes in the input layer which caused this to
be identified in sysfs where it wasn't before.

Note You need to log in before you can comment on or make changes to this bug.