Bug 116600 - up2date hang when updating smp kernel
up2date hang when updating smp kernel
Status: CLOSED DUPLICATE of bug 116582
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
All Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 12:50 EST by Peter Chiu
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Chiu 2004-02-23 12:50:35 EST
Description of problem:

The system is frozen when up2date is launched from a cron job.
It is later found that the kernel-2.4.22-1.2174.nptl was 
successfully mounted, but not kernel-smp-2.22-1.2174.nptl.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.22-1.2174

How reproducible: happened twice


Steps to Reproduce:
1. set up a cron job with /usr/sbin/up2date -u
2.
3.
  
Actual results: Most updates are done successfully, but
when kernel-smp is involved, the system will freeze.


Expected results: kernel-smp is updated


Additional info:

We use up2date to keep our FC1 box updated every day in a cron job.

Most often, the job completes successfully without trouble.

But when kernel-smp is involved, somehow the system will get locked up
and no activity will be allowed.

The cron job log will show:
...
Installing /var/spool/up2date/kernel-smtp-2.4.22-1.2174.nptl.i686.rpm
and stops there.

The /var/log/up2date.1 will show
[Sat Feb 21 04:16:50 2004] up2date Creating rollback packages...

and stops there too.


It is noted that the kernel (kernel-2.4.22-1.2174) is successfully 
updated on the system and reflected in /boot/grub/grub.conf as an 
viable option.

However, there is no such option for kernel-smp-2.4.22-1.2174.
Also, there is no /boot/initrd-2.4.22-1.2174.nptlsmp.img produced.

Under /var/spool/up2date, the kernel-smp-2.4.22-1.2174.nptl.i686.rpm
is successfully fetched.

Indeed, I can get the problem by forcing a rpm update:
rpm -force -Uvh kernel-smp-2.4.22-1.2174.nptl.i686.rpm

and the kit is successfully installed and reflected as a valid option
in /boot/grub/grub.conf.

Hence, I suspect there is a bug here with up2date when handling 
kenerl-smp update.  I rank this as high priority as the system 
is unusable when the problem strikes.
Comment 1 Bart Martens 2004-02-23 15:17:08 EST
Duplicate of 116582.
Comment 2 Aleksey Nogin 2004-02-23 19:47:30 EST

*** This bug has been marked as a duplicate of 116582 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.