Bug 116601 - cdrecord-ing not working on kernel 2.6 since core 2
cdrecord-ing not working on kernel 2.6 since core 2
Status: CLOSED DUPLICATE of bug 116622
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 12:59 EST by Mart
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mart 2004-02-23 12:59:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
After updating Fedora core 1 to core 2 test 1, the cdrecord utility
doen't find any IDE CD writer anymore, though there is one as /dev/hdc.

cdrecord does find the SCSI scanner:
[root@bluebird spinvis]# cdrecord -scanbus
Cdrecord-Clone 2.01a25 (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Linux sg driver version: 3.5.30
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.79-RH '@(#)scsi-linux-sg.c      
1.79 04/01/14 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) *
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) 'HP      ' 'C5110A          ' '3638' Processor
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) 

It doesn't find any IDE CD writer, like with:
[root@bluebird spinvis]# cdrecord -scanbus -dev=ATAPI
Cdrecord-Clone 2.01a25 (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
cdrecord: No such device or address. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.




Version-Release number of selected component (if applicable):
cdrecord-2.01-0.a25.2

How reproducible:
Always

Steps to Reproduce:
1. cdrecord --scanbus dev=ATAPI

    

Actual Results:  cdrecord: No such device or address. Cannot open SCSI
driver.


Expected Results:  Listing of my IDE CD writer

Additional info:

This utility always worked fine under Red Hat 9 or Fedora core 1.
Since core 2 with kernel 2.6 it doesn't work anymore.
Comment 1 Bill Nottingham 2004-02-23 18:47:04 EST
What happens if you just pass dev=/dev/hdc?
Comment 2 Harald Hoyer 2004-02-24 04:01:08 EST
and did you remove hdc=ide-scsi on your kernel command line in
/etc/grub.conf???
Comment 3 Mart 2004-02-24 11:06:27 EST
OK. Bug solved. I removed hdc=ide-scsi from the kernel command line
and cdrecord works with the command:
 cdrecord -v speed=16 dev=ATAPI:0,0,0  -audio *.wav
and scanning with 
  cdrecord -scanbus dev=ATAPI


Thanks.
Comment 4 Bill Nottingham 2004-02-24 11:56:36 EST

*** This bug has been marked as a duplicate of 116622 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:01:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.